Visual studio 2015 community edition fails to install

Hi everybody,

i just wanted to package a project from u4.12.4 and suddenly unreal engine tells me to install visual studio 2015 community edition for that.
i never had that before … the last time i built a project it worked out of the box (its ca. 2 month ago…)

now i downloaded the file that was suggested by the engine and started it.
it crashed right during the visual stuiod splash logo …

i tried every installer i could get from microsoft and even got the iso-file.
the problem stays the same.

i disabled firewall and antivirus software and closed every program i could but i still cant get past the splash screen
i ran all files as an administrator under windows 7
i even did an update to windows 10 but the problem still remains …

so i have to deliver a project in the next three days, and currently i cant cause i cant install visual studio 2015

is there any other way to get the game packages ?
or does anybody has an idea why the install crashes all the time ?

kind regards


Hello stucki,

While your Visual Studio installation failing is definitely a problem, I believe the main issue here is that it is being required. If you haven’t added code to your project directly, the culprit is most likely a plugin that is needing to be rebuilt. One of the most common plugins that people have reported this with is Substance. Can you check to ensure that you don’t have a plugin enabled that needs to be recompiled?

Hi Mathew,
thx very much for this hint.
After disabling the substance plugin, ue4 starts to package the project without needing visual studio 2015 community edition any longer.
that really saves my day !!!

but what will i have to do when i will need the substance plugin for a project in the future ??
i tried to install visual studio on my laptop and it worked without any problems …
the same win10 upgrade over the same windows 7 version.
i could see that on my laptop the installer (during splash screen) for a very short moment starts a second window and closes this again. at this point my pc aborts the installation …
Any further hint what could break my pc but didnt my laptop ??

but once again, thx very very much !!
kind regards

I’m not exactly sure as Visual Studio is a Microsoft program. Where did you download the installer from? Was it from Microsoft’s website? Does it give any error messages? Do you have any other versions of Visual Studio installed? If so, can you try uninstalling those and then reattempting the Visual Studio 2015 Community installation?

We haven’t heard from you in a while, stucki. Are you still experiencing this issue? If so, please refer to the questions in my previous comment. In the meantime, I’ll be marking this as resolved for tracking purposes.

Hi Matthew,
i just downloaded a new plugin for my game i want to use and the same problem arises again.
i still cant install visual studio community 2015 on my win 10 64 bit system.
i uninstalled all older versions of it (though i had to do this manualy via cmd with some microsoft tools, because uninstalling them via app menu lead to the same error than installing …
i tried the webinstaller, downloaded the iso from microsoft, but still no luck.
after executing the installer i can see the logo for a moment and than installation aborts without an real error message…

i really am very frustrated right now…
has anybody the same problem.

i guess it has to do with the upgrade from win 7 to win 10.
i had the same issues under win 7 … i hoped the upgrade had done the trick but still no chance for me to install it.
so i cant build a game with unreal engine right now …

kind regards

I would suggest speaking to Microsoft’s support staff about issues with installing Visual Studio as this seems to be an issue between Visual Studio and your Windows installation. Unfortunately all I can currently suggest to work around this would be to disable the plugin. You can do this by editing your .uproject file with a text editor such as notepad and disabling it manually from there.

HI Mathew, thx again for answering here !
i have been in contact with microsoft for some time now, but we had been at the point where furtther help had to been paid for … so i tried to ask here, if somebody else had experience with this problem )

I am glad to say that the new community edition 2017 rc fixed my problems.
it installed without problems ( now i only have to wait for ue4.14.1 ) and hopefully my problems are belonging to the past, then :wink:
kind regards