Download

Visual Studio 2013

Whenever I press the “Install Visual Studio 2013” button i get an error message about compatibility issues, I press ok, on the bottom-right corner a “downloading visual studio” tab appears and nothing happens.I’ve been waiting for a while and the tab is still there, no progress happened.
Then I tried to install it manually, but no matter wich version I install, none of them seems to catch UE’s attention.
I’ve been trying to find solution for this problem here but didn’t find anything so I posted here in hope for some help.

Hello Butyi,

You can find more information about this problem at the following post.

Usually you have to install VS before you install Unreal. That’s the way I’d recommend doing it anyway.

Try un-installing the engine, then grabbing VS from here: Download Visual Studio 2019 for Windows & Mac (I can’t find the 2013 Edition, but a colleague tells me that 2015 works fine for him).

Once installed, try installing the engine again.

You can still download VS 2013 Community choosing from the menu located on left side of the page =)

Still not working, I’ll try to download the 2013 version as suggested above

Did the install finish or not?

Visual studio’s installation “freezes” often. Had the same problem.
The only solution i know, is to restart your computer every hour or so. Don’t cancel the installation yourself, but only when the shut down asks to close remaining open programs.
After the restart it will resume automatically.
I have professional and community installed on two machines the same way.

It went smoothly whitout any error messages, I have downloaded and installed the 2013 one, it installs, but at the end it says “not every aspect has been installed” but it is still there runnin and stuff, but UE still does not want to accept it :confused:

Are you using Windows 10?