Vislog crashes when changing controller selection

When I run the visual logger in 4.18 while running the editor through Visual Studio and try to inspect more than one controller I always get a crash in AVisualLoggerRenderingActor::ObjectSelectionChanged when I switch to the second one. I was able to reproduce this in a blank project with the following steps:

  1. Create a new code project with a blank template, no starter content.
  2. If the engine opens automatically, close it and run through Visual Studio instead.
  3. Add a Nav Mesh Bounds Volume to the default map.
  4. Create a blueprint inherited from BTTask_BlueprintBase. Make a Blackboard Key Selector variable and add the following to its Event Graph

5. Create a blackboard and add a Vector key.
6. Create a behavior tree and set up the tree like

(BTT_FindMoveLocation is the task from step 3).
7. Make a new Character blueprint, in Begin Play have it run your BT.
8. Add 2 of those characters to the map.
9. Run vislog and start PIE.
10. Once both controllers have entries in the vislog select one, then the other.

I’m also attaching my [repro case][3].

If you run the project my double-clicking the uproject instead of debugging through VS this only causes a hang for a few seconds before recovering. I also tried this with the Strategy Game example available through the learn tab in the launcher with the same results. If I run it normally it has a long hang but continues working and if I debug through VS it crashes in the same spot.

Hello ,

The reason this only appears as a hang when running the project normally is because you’re hitting an Ensure. Ensures are similar to asserts but they are handled and allow the process to continue. When you encounter one of these while debugging, it’ll cause the process to trigger a break. You should be able to continue after that however, unlike an assert.

This is still a bug so I’ll be reporting it after a try a couple different versions, but I wanted to let you know that.

Hello ,

I apologize for the delay but upon further testing it seems that this issue was fixed in the 4.19 previews. Can you test there to see if you are running into the issue?

Nope, not happening for me in 4.19, looks fixed to me as well. Thanks.