Virtual joystick opacity do not work

I changed virtual joystick’s active/inactive opacity
but they didnt work.
just work for 0 or 1

Is it known issue?

Hello joonitto,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints that may be involved?
  1. i did. same issue
  2. steps:
  1. make a clean project
  2. project setting → input → add Default touch interface → run project → move and check joystick’s active/inactive opacity → inactive opacity is ‘0.2’ but it work like ‘1’
  1. screen shots

** additional information :
It totally works in Engine ver 4.8.2.

Hello joonitto,

After doing a bit more digging I was able to find that this is a known issue (UE-25325) and that it has been reported to the developers for further consideration. I will be sure to bump up the community interest for this issue. Thank you for your time and information.

Make it a great day

Thanks for digging in Rudy. I noticed this issue as well and would like to add that it’d be great if we can have an option to make the virtual joystick be inactive at activation time.

Currently it looks ugly when you activate it and it pops up for a second, then goes back to being inactive (if you are using that feature of course. I can’t think of a way to work around this either as opacity doesn’t work and can’t by altered at run-time afaik (in which case you could’ve made everything temporarily 0% opaque for x seconds to hide it).