Virtual joystick blocking screen space widget interaction

Hey all,

I’m wondering if there is a way around the issue I’m facing.

I have a widget that is in screen space, that widget has a button on it when I launch the level it in the editor all work great, I can click on the button and it doesn’t what is expected.

However, when I launch it to an android device I am no longer able to click on the widget button. The virtual joysticks allow me to navigate the level still but interaction on the widget seem to be blocked.

So I disable the virtual joysticks and launched the level again and the click event works on android.

So my conclusion is that the joysticks are blocking the event from happening.

I have tried to add a widget interaction component to simulate a click. I can see the device is receiving the event but it’s still not getting through to the widget.
Is there something I’m missing here?

Many thanks in advance

Anyone can help?

Pretty sure the same occurs on iOS with screen space widgets as I recall. Pretty sure it’s an unresolved bug. I recommend trying out an alternative mobile joystick like UTC (universal touch controls) plugin to replace the default ones. Should solve the issue for you.

can u plz go in more detail ?