Virtual Camera - When Rendering Sequences VirtCam UI is imbedded in the recording

Please Help, At wits end.
Have been using the virtual camera to record virtual sets, everything is working great, when I play back my sequences within Unreal Engine, everything is great. However, when I try to Render them out to a media file, AVI, MOV, whatever, I video always has the graphical UI of the virtual camera imbedded over the video I render.

I have been looking for a solution forever, it happens no matter what I do. I’ve searched the internet as best I could, read through the manuals as best I could and I’m completed Baffled. If anyone knows how to help, please let me know…


check the level blueprints to see if it’s loading a hud?

Having issues too, did you fix in the end?

following this thread as I’m experiencing the same problem.
deleting the vcam actor from the map completely at least allows me to render normal cinematic cameras without the overlay.
but otherwise, any vcam scene/take is rendering the overlay, tried to disable everything, not sure where it’s coming from…

a workaround would be to find the VCam2 UI Widget and set the opacity of the top UI node to 0


Plan V Tools - Virtual Production - Unreal Engine Forums

Could this instruction work,

Changing the game mode used to render the sequence would fix this.
In the Render Movie Settings, find the Game Mode Override setting and set it to **GameModeBase **as shown in the screenshot below.


I believe ^ that’s how I dealt with a similar issue in the past.

I created two different game modes - one where the HUD was enabled and one disabled for rendering. Then in my virtual camera blueprint, I have the ‘add to viewport’ nodes for the HUD behind this query:

AKA: Get the game mode > Is the game mode = ‘03_RenderMode’ ("_1" is on or “_0” is off) and then have fed the output into a branch node which controls the add to viewport.

Changing the game mode has no affect in this case

To be clear, I am referring to setting up the blueprint so that the HUD is only enabled if the game mode is set to something specific. Eg. if your game mode is ‘Previz’ then it will draw the hud. But if you set up the game mode for ‘Rendering’ then it will not. That’s what I have done with mine using the above screenshot. That drives a boolean into a branch node. If true it enables the hud. If false it doesn’t. Then naturally you set your game mode to previz for capturing the the scene and ‘rendering’ for export. If you have correctly set this up, then outside of having the hud enabled in render settings, I am out of ideas.

Is editing the blueprint still the best solution for this? I imagine it must be a bug that needs fixing at some point

Hey guys,

I was facing the same issue and bumped across this video tutorial. Saved my life. Worth a look I guess

Cheers !

Did anyone find a working solution for this?

This is the solution I found after hours and hours of googling. This issue was such a pain in the ■■■ until I found this method, I wanted to make a video and share. Hopefully when people are googling and doing their head in like I did, they find this useful.

I know this is 800 years old, but I was having the same issue. I fixed it.

All I needed to do was select the “VirtualCamera2Actor” in the Outliner, click on the 'VCam; component, then go into Output Providers > Index > Output, then switch the UMG Overlay to “None”. This worked like a charm!

You can do this after you’ve recorded your take, so you don’t have to fly blind. Just turn the UMG off at render time, or when in Sequencer.

1 Like

Virtual high five… cuz this is exactly what I was looking for - it works!
…so thank you for adding this to the 800 year old thing :slight_smile: