Download

Virtual Camera 2 - No Livelink

Hi all,

I’m wondering if anyone has had any success with the new virtual camera that comes with 4.26.

I’m following instructions here:

But do not get any listing in the Live Link message bus.

The ipad will connect to UE4 with the legacy camera, so I don’t think I’ve got network / firewall issues.

At the stage where it might expect a live link connection to be listed I stil have Unreal Remote 2 app saying “Connecting”.

The best I can manage is when I enable the cam I get colour bars and “No signal”. Never any Live Link.

I feel I’ve tugged at every thread I can find for now… be great to hear if it worked for anyone else!

Thanks,
r.

I’ve been having the same problem.

What build date do you see when you launch the Unreal Remote 2 app? Mine says Sept 19 2019, whereas the screenshot in the instructions shows a build from Nov 15 2020 (and a different interface). My guess was the new Remote app was not available in the App Store yet? Has anyone gotten this to work with the new vcam?

Ah good spot. I’m seeing the same dates / versions. I reckon that’ll be the issue. It’s at least solid enough info to post in the UDN… will let you know how it goes. Thanks!

Yes! I spotted the same. Hoping they get to update the plugin on the app store and aren’t having any issues with that! It’s a 2019 build for me too :frowning:

Did you ever get any answers?
I still haven’t been able to make this work.

Thanks​​​​​​​

Hi,

There’s been no update on this so far. It may be possible to make it functional without LiveLink by hacking it a little to operate like the v1 vcam - but I haven’t tried.

I have reported it as a bug.

Hi,

Still nothing about this?

HI all. I was having problems as well. Found this on the Virtual Production group on facebook. This is the version you need for it to work with 4.26.

From **Ryan Mayeda on the 23th of December. **

I’ve seen this come up in a few threads and feel like it’s worth a full post, so here goes!
For those looking to try out the new 4.26 Virtual Camera features, we (unfortunately) weren’t able to get the update into the App Store for Unreal Remote2 that supports Live Link and in-editor usage. In the meantime, anyone interested can grab it from Test Flight with this link (be sure to install the Test Flight app first):

NOTE YOU NEED TO DO THIS ON YOUR IOS DEVICE WITH TESTFLIGHT INSTALLED! NOT ON YOUR PC!

https://testflight.apple.com/join/BG50aCiN

The App Store version will be updated in the new year, but it’s still meant to be a stopgap for a dedicated Virtual Camera app that is getting close to release-ready (yay!). We also hope to have some performance/latency improvements for streaming to iPads in 4.26.1.
For information on the 4.26 Virtual Camera features, check out the docs, which have been updated and will require the new Unreal Remote2 app linked above.
https://docs.unrealengine.com/…/VirtualCamera/index.html
Thanks for your patience with us on this and we hope you enjoy the new Virtual Camera stuff!

Hope this helps.

Thanks for the info, Jaeger!

Thanks jaeger! And thanks to Ryan Mayeda too

Stil not working, even with the Testflight versionl, endless stream of these errors in the Output log:

PIE: Error: Blueprint Runtime Error: “Accessed None trying to read property PlayerController”. Blueprint: StatusBar Function: Update Scene Number Text Graph: Update Scene Number Text Node: Get Current Recording Slate
PIE: Error: Blueprint Runtime Error: “Accessed None trying to read property PlayerController”. Blueprint: StatusBar Function: Update Take Number Text Graph: Update Take Number Text Node: Get Current Take Number
PIE: Error: Blueprint Runtime Error: “Accessed None trying to read property PlayerController”. Blueprint: StatusBar Function: Update Fps Text Graph: Update fps Text Node: Get Current Recording Frame Rate

Hey! I found a solution (thanks to Moo Chung). This problem is not in the iOS device. Not in the Unreal Remote 2.1 update. The problem is in the engine config (it was fixed in 4.26). Solution:

  1. **Go to the place where your engine is located **in the desired directory to the config *(C: \ Program Files \ Epic Games \ UE_4.25 \ Engine \ Config \ BaseEngine.ini)
  2. *Find the line about Remote Session:

([RemoteSession] + ChannelRedirects = (OldName = FRemoteSessionFrameBufferChannel, NewName = FRemoteSessionFrameBufferChannel_DEPRECATED))

should work:

([RemoteSession] “+ ChannelRedirects = (OldName = FRemoteSessionFrameBufferChannel, NewName = FRemoteSessionFrameBufferChannel_DEPRECATED)”

Just delete it or put it in quotes starting with “+”. Vaul Remote Session Plugin (along with Virtual Camera) - Works on 4.25.4!

Hey, I’m having the same issue. did you find a solution?

I’m using UE4.26.2 with Unreal Remote 2 v2.2.065 Build on March 24, 2021

No, I didn’t