Viewport issues

Hey everyone. Coming back to unreal after a couple of years break (since UDK). Trying to go through the new Udemy course and seeing weirdness in my viewport.

  1. Grid lines are flickering when I have a brush level with them. Turn off antialiasing in view?

  2. My geometry seems to disappear occasionally if I switch from lit to unlit and back a few times…seems to stay that way even after shutting down the editor and reopening project.

  3. my geometry seems to always be transparent…which gets distracting.

I’ve been Googling around trying to find some easy answers. Don’t seem to be getting any.

Using 4.15.2. Dell gaming laptop Inspiron 7000 with nVidia GTX 1050 Ti with latest drivers

Any thoughts and/or settings to try?

Thanks everyone


Really sounds like you’re having some hardware or driver issues; all the items described above sound like it.

Reinstall drivers maybe?

Are you using vanilla UE4 (the UE4 from the launcher) or are you grabbing a build off of github?

I was kind of thinking the same thing. It’s a new laptop…I wiped out and reinstalled windows 10 with all fresh vendor drivers. But that was about 6 weeks ago. I can check for nVidia drivers to see if there’s something new.

I’m just using vanilla UE4, no github builds.

This guy seems to be having the same issue. His fix was to turn off the Realtime option in the view port. That does change the flickering for me too, but…seems like a hack.

Also, this laptop has 2 cards. The GTX 1050ti and an intel that I think the display is using. I’m wondering if I make the display use the GTX that might help?


Yes you definitely want to use the GTX 1050- not the onboard intel graphics

Normally laptops will use the Nvidia card for gaming and high end real time rendering software, but hey it’s computers and sometimes things don’t work the way they’re supposed to. Double check and make sure. Each laptop is different, but if you check your settings in the NVidia control panel or the Win10 system settings you can manually choose which graphics chip to use.

I haven’t had the same problem as you; but when I got my new laptop a few months ago, one of the first things I did was go into the system settings and force my GTX 1070 as the default graphics chip to use all the time.

Ok…the problem is not my laptop. I got home and downloaded the latest UE4 to my home dev rig. It’s also running a GTX 1050ti, but it only has one video card. I’m still seeing the flickering.

And when I create a new empty level, put a block in, go to unlit and then back to lit. the brush disappears. I build/rebuild…try lights only…it’s still gone. It is because there’s not a light source maybe?

Anyone else having this issue?