Viewport has suddenly gone black

Using 4.26 but for some reason that tag wasn’t showing.

I’ve never had this happen before and I’m perplexed. While working on my project, my viewport has suddenly turned pitch black. This is regardless if lit or unlit, wireframe, etc., and yes, I have lighting. I’ve been working on this project for close to a year now and this is totally new.

I can see all the objects are still in the world outliner, and if I go into an orthographic mode (top, bottom, etc) I can see things, but only then. I would assume something is affecting the lighting, but then I question why I can’t see anything in unlit or wireframe mode.

I’ve tried closing and reopening the project, but no difference. Tried reloading the map as well. Tried building the scene. Test playing the game works fine, the issue is only when in the viewport while editing.

I wasn’t doing anything related to the lighting when this happened. I was working on a simple object floating component, nothing fancy.

Maybe you can try open another viewport, main menu - window - viewports - viewports 2 or 3 or 4, see if it works.