Viewport camera moves on its own!

This thread is still saving lives. I would have never thought to disconnect the controller. Thank you !

This saved me too xD

Omg and i was wondering is it my keyboard going crazy ? :stuck_out_tongue: Thx a lot

Hello Guys
I don’t know what’s going with my VR The camera Goes up to the sky every time i press play i need help with this please Thank you and have a bless day

I’m having a similar problem but with a twist.
I’m trying to control the camera with a Vive controller, which is happening with no problems.
However, as the scene is big, I’m multiplying the relative transform of the controller for 100 and using that to set the relative transform of the camera.
As a result, the camera starts moving faster and faster, even with the controller stopped.

If it is the relative transform I’m setting, when the controller is stopped, it should move 0 or something close to that right?
Am I missing something?

Thanks in advance for any help!

Your camera is probably possesed! Exorcise your CPU.

OMG! @fighter5347 dude, you saved my keyboard. I had been facing this since two days and thought my keyboard key is getting continuously pressed! Hit it so hard so many times! LOL! :slight_smile:

This still happens. The easiest fix is to do this:

Go to Editor Preferences->Level Editor->Viewports and turn off checkbox “Level Editor Joystick Controls”.

Would be great if Epic would fix this though :slight_smile:

-Chilton

I just wanted to echo that this thread also saved me a tons of time in trying to figure this out. :slight_smile:

lol i was trying to figure this out for 30 miuntes!