Videos doesn't play when packaged

Hello, I have some problem here, I put my videos to level and setup them to show when I click [Play] and they played well, nothing happend but when I packaged my project, the movies material became white or mean cant show the video

So my problem is videos doesnt play in packaged project

I’ve looking for too much question like this and didnt have a problem solve… pls help me :frowning:

the pictures show:

When I play in editor, the videos nothing happend:

And this is after packaged…:

Are your source videos located in your “content/movies” folder?
On mobile they have to be there, otherwise they are not packed in the final game…

Yes the video content is in the project correcty, I played well in editor but packaged not :frowning:
Do I need copy video content to packaged project folder too?:

Have you checked the packaging settings?
Do you also call a media player play, or are they setup to start play when they are opend?

yes, you can see my level blueprint in first picture… but wait… whre is media player play in package setting?

ok I’ll send u more picture

Is this enough? sorry cuz I’m new so lots of thing I need to learn, I add videos like UE4 tutorial did

In your picture of the level BP you just load the video into the player, unless you have not set the source to play on open the video will not start.

Have you checked the box “play on open” in the media player asset?
Also just for testing: just unplug the other two media player nodes so you are just working with one.

hm thats weird.
Can you set up a basic level with just the media player and check this out? Just to make sure that it isn’t the movie? Maybe try a mp4 movie instead of a wmv

Here, everything is so smooth :frowning:

oh lol, do I need to tick the save playlist?

u can see in my folder have a mp4 format, I tried mp4 first and I saw not work and I convert and try wmv and still fail… :frowning: