Video Texture Issue on Gear VR

Hi, I was wondering if you could help me with some an issue on the Galaxy Note 4.

Despite the massive push to support the Samsung Gear VR, playback on the Samsung Galaxy Note 4 currently unfortunately seems to be broken. Since experiencing cinema in VR is one of the primary selling points for the Gear VR (one of the main demos shipped with the device), I thought maybe you guys could help us by fixing this feature for the Galaxy Note 4 (the phone required by the Gear VR). Cinema in VR would be awesome with this device, and is the main feature of an app we are trying to do. Suggestions on who I can ask about this issue? Thanks!

Chris Babcock (engine developer at Epic) writes that .mp4 video textures are currently working for Android 4.0 and up since UE4.7: Video / Media Texture stay black [Android] - Mobile - Unreal Engine Forums

(see in particular comment #6: Video / Media Texture stay black [Android] - Mobile - Unreal Engine Forums )

However, from my experience and that of others on this page (Mobile Dynamic Shadows & Movie Playback - Mobile - Unreal Engine Forums) it would appear that some devices currently aren’t working.

Thanks again & best wishes

Hi chrismcclellan,

Can you elaborate on what is the exact issue you’re seeing on the Galaxy Note 4?

Thanks for responding Wittlief. This is what I experience:

Applying a video-texture-based material to an in-game object or surface results in a crash upon launching the app on the Galaxy Note 4. Immediately upon opening the app, a pop-up message says that the app has stopped working.

The video material plays properly on the object surface when playing/running the game within the editor, so I believe it is set up properly. And clearing the URL field for the target video of the involved media player eliminates the crash (but also, of course, removes my nice video texture).

Thanks again Wittlief!

I have tried both MPEG-4 and h.264 compressed mp4 video (both with AAC-compressed audio), as well as a renamed copy of the video file recommended by Chris Babcock here:

Do you mind attaching logcat logs of your crash to this thread as a txt file? Verbose logs are preferred.


Hi chrismcclellan,

Were you able to locate the requested logs?

Hi chrismcclellan,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

Hi, I don’t know if you ever resolved your issue, but I had the same problem. How big was your video file? In my case, the crash was due to the apk file size, which was over 1GB (I included the video files inside the apk, I don’t know how to tell the program to find them otherwise). I solved it reducing the video file size.