Video Texture Bug? Wrong Compression? (Gear VR / Android)

-----------------Short Version-----------------

Need info urgently on using mp4 video textures on Android (relating to the new Media Framework & Android Media Plugin). Very interested in exact video and audio compression needed for the mp4 video for playback on the Samsung Galaxy Note 4 for Gear VR.

The Gear VR has been touted for it’s ability to watch videos in VR. This capability is urgently desired by one of our big customers. I’d like to get in touch with any employees at epic who designed the Android Media Plugin or are knowledgeable on this development. Thanks!


-----------------Detailed Version-----------------

I can get the first person example map to deploy correctly to the gear vr (packaged using ETC2 textures), and have discovered a couple strewn comments across the internet by epic employees who mention the new media player capabilities (for in-game video textures) are indeed working for Android (despite complete lack of documentation of this capability). These unofficial internet comments claim that support for .mp4 video playback on Android has been finished since 4.7.

Adding an .mp4 video material freezes my packaged app on the first frame of my game. And yes, [1] importing the video as a material texture and [2] playing it’s attached media player, are the ONLY two things I changed about the project, and this resulted in the app crashing/freezing on Android (playing/simulating the level in the Editor viewport works just fine, the video texture works as intended).

These employees say to use an .mp4 file, but I need to know which video & audio codecs it needs. I wish I could find the person who wrote the Android Media Player Plugin for Unreal Engine. I am currently trying to play an .mp4 with MPEG-4 video compression and AAC audio compression.

I cannot obtain the logcat as my Galaxy Note 4 is plugged into the GearVR. Can you refer me to the name of this employee, or refer him to my question so I can have it answered? Or just a sample .mp4 would be fine. Thanks so much!!

Unreal Engine (v.4.7.6)  (4.7.6-2513093+++depot+UE4-Releases+4.7)
Android Media Plugin (v1.0)
Gear VR Plugin (v1.0)
Samsung Galaxy Note 4 (SAMSUNG-SM-SM910A)
running Android v5.0.1 (API 21)
nVIDIA NVPACK + Android Works
Android API's installed: 15,16,17,18,19, & 21
minimum Android Target set to API 19 everywhere

(followed the instructions in this video exactly: Up & Running with Gear VR | Live Training | Unreal Engine - YouTube)
(although I have also tried setting target to API 21)


Hi! Did you ever find a solution for this? I’m trying to do the same, in UE 4.10.2. My game doesn’t get freezed, but I’m stuck at 12 FPS (without the video I can reach 60 easily).