Download

Video is not included in packaged game file

Hi,
I have packaged my small exhibition game for windows platform which includes lots of TV’s. In editor and in game it works fine. But, when I send it(the game) to other computer it doesn’t work. It also does not work if I change the source video files folder name. How to fix this? Please help me.
Thank you

You have to manually include the videos folder in the package.

How do I add it(video files) manually? Any tutorial or source to know? Also let me know if I create a compressed version will the process work with it as well?

I have another question for you after this is solved as you have shipped a game on steam. You must be very knowledgeable developer. That question is, My exhibition hall is only a big place with lots of stands. Most of them are copied from 4 stands to 12 stands. Also I maintained low poly in the polygons of the objects.Still the packaged size is 21 GB and compressed packaged version is 11.5 GB. Why is it so big?

Thank you for your reply.

When you package the game, you end up with a folder called, maybe, WindowsNoEditor. You have to copy the movies folder from your project to that folder, in the same place.

If you just package directly from your development project, the system will put EVERYTHING in the package. To stop that happening, just select the maps you want to package in the project settings:

I tried to follow your steps for the videos, it’s not working.

You put the movies in the folder:

C:\Users<Username>Documents<Path_to_your_project>\Content\Movies

It’s exactly the same relative place as when it’s in your editor project.

Hi,
I tried it before you said. Still it’s not working. I don’t know what is wrong. It is driving me crazy.
Thank you for your reply.

That’s all I can say I’m afraid. Look where the movies folder is in your project, it has to go in the same place in your packaged game.

Hi,
I’m really sorry for bothering you. Let’s check from the beginning. Does movies folder come automatically in the content folder or I have to create a folder by myself, which is called movies. Because I have created a folder called movies. Where all the videos are in there.

You are a very helpful man. I hope it will be solved if you can give me a bit more push to go forward if you have a free time only.
Thank you

I can’t recall if the movies folder is there by default or not. If not, just put it there, in the content folder.

When you package your game, the movies folder does not get copies. So you just copy it, to the same place, the content folder, after packaging.

That’s it :slight_smile:

Hi,
Thank you for your answers. But, I added the videos in same place as movies and it’s not working if I change the source name. It doesn’t collect the videos from movies folder. It wants to collect videos from that source not the movies folder.
Thanks a lot for the helps.

UPDATE

Hey,
I got the solution. I didn’t even need to add the videos to the game file after packaging. The problem was, the videos were on my desktop folders and was linked through the path. The video had to be in the content folder, not in the engine, you have to add the videos manually to the content folder>movies folder. The mistake I did was, I linked the videos which were not inside the content folder physically.
Thank you so much !

That what I was saying all along… :wink:

Thank you for the helps !