Video insertion problem in UE 4.15

Hello,

I would like to insert a video to my scene in UE 4.15, to be able to create a video room environment in Vive but it does not let me to insert the video as texture (can do it in editor but does not work when I play the scene). This function was working properly in 4.14 but I could not find a solution for 4.15. But there is no way for me to go back to 4.14 due to scene requirements. Is there anyone who can guide me? Thank you.

Hello AtalanTech,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue on our end?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any settings/blueprints that may be involved?

Hello AtalanTech,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Thanks,

Hello Rudy,

First of all I would like to apologize for my late reply. We are still experiencing the same problem, tried everything but could not resolve it. We can only play the video on our scene when the media player is open. When we close the player, video disappears from the scene. I will share step-by-step screenshots if required. Thank you.

Hello again Rudy,

Thank you very much for your interest. I am writing to share screenshots of my case, you can find them below:

  1. Video and audio files are defined, blueprint added.

  1. When we play the video on the media player, it also plays on the scene, can be seen on the background.

  1. When we close media player, video on the scene also stops working.

I hope you can help us with these information. Looking forward to hearing from you.

I noticed that you have opened the Source but you did not include a play node. I have provided an example below. Could you try this and let me know if you are still having the same issue?

Example:

Hello Rudy,

Thank you for your answer and example. We have tried to add play node to our blueprint (we tried that earlier also), but still experiencing the same problem; as soon as we execute play, video disappears from the scene. It feels like the project fail to access video file location when we play the scene.

After taking another look, I noticed that you have “Play on Open” unchecked in your media player. Could you try checking this option to true (along with the suggestion above) and let me know if this helps.

Hello Rudy,

We tried that also (were checking “play on open” on our original tries but missed out when we were taking the screen shots) but it did not work.

But I would like to tell you that the problem is solved thanks to all your help. In case anyone else experience similar problem; It seems there were 2 different media players in the content and when we merge, engine was probably calling the video from the one which was not defined to play the video. We changed the blue print to fix to locate right player, it started to play perfectly.

Thank you very much again.