Video driver crash on startup (4.7.1)

I’ve installed UE4 for the first time. After creating a new project and loading the editor, the editor chugs along at a very low framerate for a second or two, and then my display driver crashes. This happens every time I try to load the editor.

I can run several graphically intensive games and programs (at max or near-max settings) for long periods of time, without issue. Only the UE4 editor does this. And yes, my drivers are up to date.

Here’s my dxdiag. Some of the more pertinent information:

Operating System: Windows 8.1 64-bit (6.3, Build 9600) (9600.winblue_r7.150109-2022)
System Manufacturer: ASUSTeK COMPUTER INC.
System Model: K30AD_M31AD_M51AD
BIOS: 0601
Processor: Intel(R) Core™ i7-4790 CPU @ 3.60GHz (8 CPUs), ~3.6GHz
Memory: 16384MB RAM
Page File: 3337MB used, 29369MB available
DirectX Version: DirectX 11
Card name: NVIDIA GeForce GTX 760 (192-bit)
Display Memory: 11138 MB
Dedicated Memory: 2976 MB
Shared Memory: 8161 MB
Current Mode: 1680 x 1050 (32 bit) (60Hz)
Output Type: DVI
Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver File Version: 9.18.0013.4752 (English)
Driver Version: 9.18.13.4752

Hey grfzkrg,

Are you loading any project in particular or have you tried multiple projects? Are you, by chance, running fraps or any other vidcap or fps software?

I personally use this same graphics card at home and haven’t had any issues, but I don’t think I’m on latest drivers. I’d like to ask that you revert to an older driver version and see if that helps. If it fixes the issue, we can report this to Nvidia that their latest driver causes crashes with the 760.

Also, dxdiag sometimes reports inaccurate display memory and I’d like to get the specifics on your GPU. Can you tell me exactly which model of the GTX 760 that you have? (Gigabyte, EVGA, etc). Maybe include a link to a store listing.

Thank you,

Matt W.

The card came with a prebuilt ASUS desktop (I haven’t experienced any of the issues listed in the product reviews – I’d assume it’s just selection bias), so the card is most likely an ASUS brand specifically designed for this desktop (the closest analogue I can find is this 2GB card). If it makes a difference, the nvidia control panel’s system information window lists the card as having an even 3072MB.

I downloaded 4.7.2 yesterday and started a new project with a different template; same problem. I reverted the drivers as far as the nvidia website would let me (341.44); same problem.

I’ve used the nvidia shadowplay quite a bit for other things, but I made sure it’s disabled.

Thanks for the quick response.

Hey grfzkrg,

Can you send me your logs found in [ProjectName]/Saved/Logs? Does the editor crash when the driver crashes? If it does, is there a callstack?

Can you try plugging your monitor in through the motherboard? I believe your CPU has integrated graphics and I want to see if there is a crash when using that. Please get your logs before trying this though.

Thanks,

Matt W.

The past few times, the driver wasn’t able to recover after the crash; I had to power off and restart the computer manually. I still have a couple of logs from when it was able to recover, which are attached.

I’ll try plugging in to the motherboard in a minute; I need to dig out a VGA cable

E: I am able to run smoothly (well, compared to crashing) on the integrated chip

Hey grfzkrg,

I’m going to reach out to our Compatibility team about doing a test with with their GTX 760 on a Windows 8.1 machine (I have Win 7 at home, so maybe that’s the key difference). We won’t be able to run this test until tomorrow at the earliest though.

I’ll report back with the results.

-Matt W.

Maybe this means something, maybe not: if I start up the editor while running on integrated, I can launch the sample project (as WindowsNoEditor) on the main GPU, which then runs fine. As best I can tell, the editor is still running on integrated during all of this

I probably should have asked this much earlier, but have you tried the Binary build from the launcher instead of source from github? I wouldn’t suspect that to be different, but can’t hurt to try.

That’s what I’ve been using so far. I didn’t want to start messing around with the source until I’d checked to make sure there weren’t obstacles like this to me getting up and running smoothly

Thanks again for the quick replies

Hey grfzkrg,

Sorry for the delay on this. The compatibility team is going through a bit of a restructuring, so they are swamped. I wanted to follow up though and see if updating to 4.7.3 has helped at all or if the issue has been resolved.

-Matt W.

I’m on 4.7.4 now and the issue persists

Hey grfzkrg,

I had another user on a good setup have some success when launching with Opengl. To do this, navigate to where you have the engine installed (by default C:\Program Files). Go to …\Unreal Engine\4.7\Engine\Binaries\Win64 and then Shift+Right Click in a blank space in explorer. Then select “Open Command Window Here”. In the cmd window, type UE4Editor.exe -opengl. (you can also try -openGL4)

I know this isn’t ideal, but it could be a temporary fix until we figure this out.

-Matt W.

Yeah it runs fine on opengl. (I wish I knew I could have done that earlier! It isn’t ideal but at least I can start getting a feel for the engine)

Hopefully that narrows my issue down a lot more

Hey grfzkrg,

Sorry for the radio silence, but do you happen to have an application called Virtu MVP running?

-Matt W.

no, I do not

I’m sorry to say that there isn’t a whole lot more we can do on our end with this one. Have you contacted Nvidia’s support at all? A driver crash like this might be on their end.

-Matt W.