Video displaying as black in built client

Hello,

We have been trying to play a small video in the UI during a co-op mission. We set it up following the steps from the documentation and the video plays in PIE, and Standalone mode. The issue we have only presents itself when we build our client for testing. In that case the video only shows up as black.

We aren’t doing a build with an installer. We are just compressing the directory after the build ourselves for the time being. The video files are in the content/movies folder in the built client as well.

We’ve tested 720x540, and 1280x720 resolutions.

We’ve tried the following file formats and codecs for compression:
AVI
WMV
MOV
MP4 H.264
MP4 MPEG-4 30fps
MP4 MPEG-4 25fps
MP4 MPEG-4 24fps

To sum up our approach thus far.
Tried a bunch of different steps that we have seen in in unreal forums, answers forums and documentation. Tested multiple resolutions, formats, and codecs. Followed steps in the media framework settings. Made sure it’s a local path. works in editor, works in standalone, does not work in build.

Thank you.

Hey SiNs_Tuebor,

This was a known and reported issue in the engine version you are reporting this under, UE-32353, and should be fixed in the 4.12.5 engine release. You might want to take a look at a similar post related to the same issue where Max P. provided a functioning set up.

Media Player not Working

Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley