Vertex count of imported FBX model


after importing my FBX model to UE4, it consists of:

2,191,476 triangles
5,640,357 vertices

while, in 3DS Max, the number of vertices was similar to the number of triangles (almost three times less, then).

Is it normal? It looks every triangle of the mesh has its own three vertices (i.e. there are no shared vertices among triangles). How can I avoid that?

That is way too high for a single model, in fact in games these days the total triangle count for things currently loaded is closer to 1million triangles.

Anyways, the reason there’s more vertices is that in game engines split smoothing groups to separate smoothing, so you get duplicate vertices when it splits up the mesh.

Also UV splits create extra verts.

Thanks! I have now introduced smoothing groups in 3DS and the resulting FBX, when imported, has around 2 million vertices, good! However, if I uncheck “recompute tangents” (i.e., tangents are read from file), then it goes back to 5 million polygons, why?