Version 4.22 and Visual Studio 2019

I recently uninstalled my Visual Studio 2017 cause with the release of 2019 and Unreal Engine 4.22 supporting it i wanted to swap to the new version. However it seems like its not possible to create new c++ projects with 4.22 if your only installed Visual Studio is 2019. It fails with:

**An error occurred while trying to generate project files.

Running C:/Program Files/Epic Games/UE_4.22/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project=“C:/Users/Eric/Documents/Unreal Projects/MyProject/MyProject.uproject” -game -rocket -progress
Discovering modules, targets and source code for project…
WARNING: Visual Studio C++ 2017 installation not found - ignoring preferred project file format.
ERROR: Visual Studio 2017 must be installed in order to build this target.


Is there a way to tell Unreal to use the 2019 Visual Studio for project file generation or is this simply a bug/not supported yet and i actually have to install 2017 again until this is fixed?

Did you change unreal source code editor? If not its in Edit > Editor Preferences > General : Source Code. You need existing project as far as i know.

This worked creating a blueprint only project and changing the default settings to VS2019 solved the issue.

is visual studio 2017 working still with unreal 4.22 or do i need install studio 2019?

It worked for me, thanks.

I still cannot create C++ project with UE 4.22 with VS 2k19. I have changed source code to VS2019.

I had same issue before.

Solved after install “Game development using C++” in “Mobile and Game” category from “Visual Studio Installer”.
I’m using Korean version VS, so not sure above is exact English title.

I’m trying to do this, but while it says the default settings are writable, the “Set as Default” button is grayed out. Would you know the problem here? Thanks.

For me, I previously set the editor to Visual Studio 2017. Deleting the corresponding config lines in Config/DefaultEditorSettings.ini and Config/DefaulEngine.ini solved this for me.

For related problems with somewhat-out-of-date engine compilation, I needed to install a previous .NET SDK (4.6.2) and uninstall a more recent Windows 10 SDK (the previous Windows 10 SDK was sufficient).

This is what solved the issue for me. The English title is also “Game development using C++”.