Verification of SSL certificates when using HTTPS

It appears that UE4 doesn’t properly verify ssl certificates when running on windows machines.

I posted details on this question :

Basically from what I gather a change was made to the CurlHttpManager recently which defaults verification of ssl certificates to false when a bundle path isn’t specified. On windows a null bundle path is fine and I believe the expected behaviour is that verification of ssl certificates is enabled by default.

https://github.com/EpicGames/UnrealEngine/blame/4.14.1-release/Engine/Source/Runtime/Online/HTTP/Private/Curl/CurlHttpManager.cpp#L486

Hello ambientenergy,

Thank you for reporting this issue. I found the particular change where this happened and have put in a bug report for the new behavior which you can find here: UE-41666. You can track the report’s progress there as well.

Have a nice day!