Velocity buffer issues with Chaos Geometry Collections

I’ve been seeing some pretty weird stuff in the Chaos Destruction in 5.0-EA.
I spent the day testing out the Chaos destruction system and how it interacts with Nanite and standard meshes within the geometry collection (GC).

I was testing chaos + nanite, and while it seemed pretty unstable, it did work. However, I noticed some weird motion blur issues on non-nanite destructible geometry collections. Enabling nanite for the given GC gives the expected, correct results. But without nanite, things get weird. You can see the smaller cube has way too much motion blur. It seems to be significantly worse when the character is rotating. Linear movement don’t seem to be a problem.

From left to right: non-destructible nanite mesh, destructible nanite GC, destructible static (non-nanite) GC, non-destructible static (non-nanite) mesh

Bonus notes: For anyone wondering how nanite and chaos interact, nanite appears to use a much lower resolution of the mesh when it is included in a GC. I haven’t found any way to alter the density. Messing with the proxy mesh settings doesn’t seem to change anything. Also, it does not increase or decrease quality at all with distance. This will result in larger than desired numbers of triangles from afar, and too little detail up close. I’m sure most of there are performance and technical factors here. The results were quite good but will likely vary a lot depending on the mesh.

I had an issue where if I tried to create a GC asset through the tool when using nanite meshes, they would disappear. I think this is a bug. The work-around is to select the asset in your viewport, and while it is selected go to the content browser and add the GC there. Replace the original mesh with your new GC, and now you’ll be able to fragment it without issue. Don’t forget to enable nanite in the GC settings and save often - I frequently crashed when editing the asset.

Nanite Mesh (L) vs Nanite GC (R) Triangle View. Below, cluster view at a distance. Notice the non-Chaos mesh has significantly fewer clusters showing due to proper detail reduction.

Did you ever figure this out? I see that enabling Nanite in Preview2 will fix this, however, on some materials/meshes the material never seems to reappear and it turns into the worldgrid grey.

Same problem, would love to hear an update if you have every found out a solution or workaround.

1 Like

Seems to be working fine for me in 5.0.1


Foreground: Fractured Nanite Geometry Collection.
Background: Standard Nanite Mesh.

I did have it replace my material once, but upon only on the original mesh. Replacing it with the created GC via the content browser brought back mats. Above is Chaos working on a nanite mesh that originally had 4 million tris.

The mesh no longer vanishes, nanite behaves as expected, and I’m not seeing any issues with the motion blur/velocity buffer.

Chaos meshes remain completely absent from the lumen scene, which is an issue for reflections and more.

Also creating and fracturing such dense meshes takes forever. I wasn’t sure if the engine had crashed. I think there needs to be some workflow improvements. Maybe you should be able to design the fractures on the fallback mesh and cook to the actual nanite after you’re happy with the results. As it stands, iteration takes ages.