Download

Vehicle setup (PHAT, vehicle doesn't move)

Hello,

I have a little problem with my SkeletalMesh and the PhAT editor.

I have created a C++ project using the C++ vehicle template. Now I want to replace to mesh of the buggy with my own mesh for testing purposes and got stuck.

I have imported the test mesh from Blender 2.74 and took care about the following points:

  1. Root bone is at (0,0,0)
  2. Bones axis are correctly align (x forward, z up) (see attached image)
  3. Chassis got a box collision object
  4. Wheels were assign a sphere collision object with kinematic mode
  5. Blender2.74 doesn t add a Armature bone as root bone anymore
  6. Scaling the mesh was done inside blender.

When I press Simulate in PHAT nothing happens, the mesh is in the air and doesn’t fall down nor does it move at all.
With Ctrl+RightMouse the mesh turns and collides with the ground but it doesn t seem to be affected by forces and gravity.

I have replaced the mesh of the AdvanceVehicle template with my test mesh and setup the wheels but this vehicle seems to stick in the air no matter what I do. I also did replace the animation blueprint.

So right now I am stuck here and have no clue how to proceed.

Can someone help me or give me a hint ?

Thank you for your help

Eduard

P.S.: The last 2 images where taken from PHAT while pressing Ctrl+RightMouse

lets start with a few tips, when you export from blender make sure you turn off “leaf bones”, second always check the size of your mesh against the third person blue guy, check the radius of the wheels in the wheel blueprint, try just adding 4 wheels to the vehicle blueprint.

not tried vehicles in a while so there might be issues i haven’t seen recently

ps before you export from blender “apply” scale rotation, and double check to placement of the root bone

I have unchecked the leaf bones, but this has no effect.
I also applied scale and rotation in blender.

What kind of behaviour do I have to expect in PhaT? Shouldn’t the vehicle atleast drop to the ground due to the gravity? Right now it does nothing.

How can I specify the radius of the wheels in the C++ vehicle template?
The actor and its component are spawned by code. My vehicle has approximately the same wheel size as the template.

basically it should just sink to ground level and not bounce off, i haven’t even looked at the code side to be honest i just use the blueprint version, can’t really help on that as i always create the blueprints for the vehicle, wheel, animblueprint

Hi,

I did some more investigation and probably found the cause. I have set all wheels to Sphere / Kinematic, this prevents the main body (Chassis) from falling down. I have verified this with a custom actor that contains a skeletal mesh component using my test mesh.