Vehicle isn't moving and adding wheel animation to the mesh offsets the location of the wheels

Hello guys,

Here I have two problems involving a vehicle location not change (even though things are hooked up correctly), and when I add an animation blueprint to my mesh the wheels are offset by some z value.

Here I see that my vehicle movement is firing, when pressed the value changes to 1, and I have actually seen my tires rotating and turning. Although, my vehicle doesn’t move at all. It stays in the same place.

This is with the animation added.

The issue with adding the animation to the mesh is that when I do add it the wheels magically are not near the vehicle anymore. But first we can focus on the vehicle not moving.

Vehicle No Animation


Vehicle With Animation


Here is the Animation Blueprint (I have also connect the model reference pose with no luck)

What this all comes down to is that the vehicle will not move forward, but I do see the rotation and turning of the tires although the with the animation the tires are moved away from the vehicle.

Might be a silly question, but… is physics enabled on all of the components? I’ve had characters move around while an attached component stays in the same world location, lol.

That’s the funny thing. They all have physics enabled, and I dragged the wheeled vehicle blueprint into the scene. I hooked up the vehicle movement for throttle and steering with my forward and right move. The value even changes, but no movement at all. I also wondered of wheeled vehicle blueprints have movable automatically enabled as well, but there is no static or movable option on them.

Found the solution. It turns out this is heavily geometry dependent. I looked at my wheels and the axis for x, y, and z were off and pointing in crazy directions. Lessons learned here is to make sure that the bones are set correctly on your vehicle. Also try to make the skeletal mesh as pure as possible meaning only have one bone per wheel and not multiple, and have one root bone as the parent of those bones.

I solved it.

You should go to Anim_Blueprint and in Class Sitting
in parent class
use VehicleAnimationInstance instead of VehicleAnimInstance

and change your anim graph same this

Instead of Picture 1 , You should work same as picture 2