Download

Vehicle disappearing when turning

Hello all!

I have made a vehicle in Maya 2015 which I have then imported as an .fbx to UE4 and to me everything looks correct.
I have followed the video tutorial from Unreal Engine (https://docs.unrealengine.com/latest/INT/Videos/Player/index.html?series=PLZlv_N0_O1gaz6eETtIxcmUDnqu5A-8At)
and I have also followed piinecone’s video (Unreal Engine 4 Vehicle Tutorial (Blueprint) - YouTube)

The problem I have is that when I try to drive the vehicle, it disappears when I try to turn. Going forwards or backwards works perfect and I have to restart the simulation if I want to be able to drive it again.
One thing I noticed is that if I try to turn when the vehicle is in the air, nothing happens until it hits the ground (If I keep holding “A” or “D” for turning, the vehicle disappears at first touch with the ground)

  • I have checked the orientation of the body and the wheels, and it seems to be correct.
  • I tried using different blueprints for the wheels, the same result for all.
  • I tried both default and kinematic physics settings in the phAT, same result for both.

Anyone who has experienced this before? Or has any idea of what I might have done wrong? :stuck_out_tongue:

just to double check, make sure the root bone of your vehicle is at 0,0,0 other wise when it lands it might incure damage which will set off the physics, if the bone isn’t at 0,0,0 the physics will flip out.

this is the do i always follow https://docs.unrealengine.com/latest/INT/Engine/Physics/Vehicles/VehicleUserGuide/

Thanks for the answer Geodav, and btw, I have watched some of your videos on how to set up a vehicle too :stuck_out_tongue: they are great!

I have checked the root bone, and it is in 0,0,0 position, will attach a picture to show.

I will keep on trying out different things, see if I can get it to work.

The attachments didn’t work, here is a link instead :stuck_out_tongue: http://postimg.org/image/9r70p0rg5/

ah not sure in the pic , but try lifting the mesh so that the bottom of wheels are touching the floor, then put the root bone at 0,0,0.
atm it looks like the root bone is still center of mesh

I tried to lift the mesh and putting the root bone at 0,0,0 like you said, but no difference :confused:

I noticed another thing while doing some testing, if I put my car on “supports” so that the wheels didn’t touch the ground, I was able to turn, but with some weird results.

While pressing “A”, which will turn the car left, only the front wheels turn, and both turn outwards.
While pressing “D”, which will turn the car right, only the rear wheels turn, and both turn inwards.

Don’t know what is causing this, but I think it is the problem :stuck_out_tongue:

Here are links to two pictures I took, one while pressing “A” and the other while pressing “D” and also the mesh, reconfigured as you told me to.

http://postimg.org/image/aybfar1nf/
http://postimg.org/image/iv9mujspt/

Edit: I tried to use the SK_Car from the tutorial, then everything worked perfect! So I think there is something wrong with my mesh, the question is what :stuck_out_tongue:

ok it looks like either you have the wheel bp wrong or the vehicle bp wrong

in the vehicle bp make sure in the wheels section that wheel 0 is the front left, wheel 1 is the front right …

in the wheel bp make 2 versions , front and rear, in the rear wheel bp set the steering angle to 0

also in the vehicle bp make sure you set the wheels to use the correct wheel bp

Thank you for all the help Geodav, but I still can’t get it to work.
In the vehicle bp, I tried all kinds of different combinations of wheel setup, including the one you wrote, but the problem still exists.
I did the wheel bp too, one for front and one for rear, depending on where to I assign the wheel bp (tried all different setups) but none where right.
Sometimes only the two left wheels turned, sometimes UE4 crashed.

According to UEs tutorial on vehicle setup, it shouldn’t matter which wheel you assign to wheel 0, wheel 1, etc.
And that is true if I import the SK_car from the tutorial, then everything works fine, so I still think there is something wrong with my mesh, just dont know what :stuck_out_tongue:

Edit: Some spelling

ok i don’t have maya so the mb file would be no use but if you can link me to your fbx then i can have a look, somewhere in my ram head there was mentioned about the type of skinning in maya soft/rigid not sure

https://docs.unrealengine.com/latest/INT/Engine/Physics/Vehicles/VehcileContentCreation/ “Binding” maybe that rings a bell other wise i’ll have to see the fbx and your UE4 files/project if possible

Ah, no the .mb file would not do you any good

Here is the .fbx file on the vehicle I am using: Dropbox - hull.fbx - Simplify your life
Here is the project files: Dropbox - testv.rar - Simplify your life

In the project, you have to open “tank_level” in the folder “tank”. That is where I have all blueprints etc.

ok a quick look at your fbx shows a few thing

  1. while i know you don’t have to use bones/joints to create vehicles i fine its easier to use them, more so when creating a complex vehicle
    2 the pivots for the wheel bones are wrong, in all cases they should be X= forward and Z= up

if you don’t do it that way then you will have problems, i know this is a pain for maya users

Yes you are right, better to use them from the start and learn them, so I can create more advanced vehicle later.
Yes you are right about the pivots, but in UE they looked right to me (not in the version I sent you, but another one I tried out :P)

So I added bones, with root bone at 0,0,0 and put the pivot at 0,0,0 too, and used the “freeze transformation” on the main mesh (don’t know if it is needed, but I read that another maya user did it and it helped), and now everything is working!
Thank you for you help Geodav, very kind of you to take you time and fixing it :slight_smile:

To anyone else in the future that has this issue as I did. The problem is very likely the order and bone names in the vehicle setup of your Wheeled Vehicle BP.
Wheels 0-1 should be front and 2-3 your back. The order between left/right is the same as it’s setup in your Skeletal Mesh.