Vehicle constantly shaking/juddering?

I have set up a vehicle by copying the wheeled vehicle template. Everything is working, but my vehicle has a constant shake, as though there is some physics problem occurring. I have set all suspension settings to zero, as my vehicle does not have suspension by design. I have also ensured that collisions are disabled between all objects in the physics asset. I have tried modifying the mass of all objects, with no change.

The only thing that has made a difference is scaling the root collision box to be very large (so large that it makes no sense in game, so it can’t be used), and turning on suspension and giving it a min and max raise/fall height (but I need a vehicle without suspension).

Applying a small amount of suspension seemed to work initially, until I tried the game in Oculus Rift(for which I am developing this game), where the shaking became even worse (not sure how this can be, CPU performance affecting physics simulation quality?)

I have also tried changing the physics substep, with no difference. I have tried setting wheel long stiffness values to different values, and none seem to make a difference. I have spent many hours trying to solve this.

Friction values of the wheels are 3.0. If I increase this higher, the shaking increases. Long stiff for rear wheels is 200 currently, 10 for front (just for handling testing), but changing these values does not appear to change the shaking.

This is the physics asset: I have tried using many different primitives for collision meshes, and they all have the same result (unless the main body is sphere, in which case there is no judder, but the car rolls).

Can anyone please help?

Is Substepping enabled in Project Settings > Physics > Framerate?

Yes, with substep max delta time 0.016667, and max substeps 6. Changing these values also has no effect on the shaking.

try playing around with the max depenetration velocity. It isn’t a complete fix but it stabilized the collision overlap a little bit on my end.