Vehicle Collision Scale Issue

while setting up my vehicle the collision on the car all seems fine on the physics asset see

however when i jump in game the collision has massively scaled somehow see

I am unsure why this is happening, as i have set it up before and it working with the same model but when i went back and fixed some material ids and smoothing groups and now this is happening.

it leaves me stuck in the ground unable to move

  • Are you scaling the car at any point?
  • Try removing the collision from physics asset and recreating them

no scaling, ive tried re importing it several times.and redoing the physics asset. the only thing to do with scale is the unit size i export as it says it scales it then by 0.1 however in engine its the correct size as as from my image the collision is the proper size

I had that a while ago, but just can’t remember how I fixed it. Things I would try as a long shot are:

  • Try fresh project and import just the car
  • Try different engine version

Turns out when i was exporting the file i changed the scale units in the export options. this scaled the mesh correctly however did not scale the point helpers for the bones. despite the physics assest showing it correctly… must be an fbx / ue4 communication error