Variable Missing and Can't Recreate


I have a Structure Variable that all of a sudden disappeared from my Blueprint, and I can’t recreate it as though it still exists (If I try to create the variable and name it, it automatically reverts to like “New_Var 0”). I can’t right click on the old variable (that’s greyed out in the blueprint it’self) and click create variable as that seems to do nothing.

I have an autosave that is like 3 or so hours behind, but didn’t want to revert if there was a known fix for this? I tried duplicating the Blueprint like someone mentioned in another thread but that didn’t work.

I have had this happen randomly before on version like… 4.15 or something which caused me to just restart my project haha (wasn’t that far along anyway at the time).

I was adding content to a Structure that is inside the Structure that has disappeared from the blueprint. But I didn’t think that would have anything to do with it? Have tried reloading as well, that didn’t resolve the issue.

Am I just going to have to bite the bullet and load an older auto save? haha


I tried reverting to an earlier save that I know was working, but the variable is still messed up on that version - It’s not in variables, but when trying to create the variable it states that it already exists. I’m just starting a new blank project and will port across as much as I can I guess.

Resolved. Figured out there was a warning saying that I needed to delete the last entry in my Structure and compile to resolve some issue? But opened of the Structure and deleted that last variable and this allowed me to compile the blueprint.

Sorry if that doesn’t overly make much sense, very tired. But hoping it does and can resolve the issue if anyone else has this happen and freak out.

1 Like