Download

Valve Index thumbsticks only return 0

Is there a trick to getting the Valve Index thumb sticks to work in UE4?
I have a VR project that works great on a Oculus CV1 and Quest with a link cable, but my Valve Index thumbsticks always return 0 so I have no movement in my game.

I first noticed this in UE4.24 and reported it as a bug, but I didn’t hear anything back and so I’ve been using my Oculus CV1 for development. I just updated to UE 4.25 and found the same issue still exists.

Is this a bug or am I missing some extra set up that the Index needs? All the other buttons seem to work, it’s just the thumb sticks I can’t get a value from. If it makes a difference I’m using C++ and not BP.

I encountered something similar - cant say for sure but after adding some additional inputs it seemed to work.

e.g

MixedReality Thu8mbstick
Oculus Touch Thumbstick
Vive Trackpad

If adding those inputs work for you be sure to post back…

Thanks for the reply, but unfortunately that didn’t work for me.

I just tried adding all the controllers as well as deleting everything and starting again, but still the same.
I did just notice if you open the Index menu while testing the game and select show bindings, all my buttons show up as bound to the key names in UE, but my thumb sticks are shown as not bound to anything.

Did you manage to solve this eventually? Ran into the same problem, it only works when click the thumbstick.

I did, although I asked a few places and forgot to update this post.

I ended up contacting Steam support and they pointed me to this thread;

Basically you need _X or _Y at the end of the action names.

Thanks for the reply. I tried that already, but will give it another go.

Having the same issue but with Oculus Touch controllers when reading the input using the respective function. The related input even also never gets called.