Validation failed when saving multiple assets

Ever since upgrading my engine version, I’m getting a strange error whenever I save two of my maps. For both of them, whenever I save the map, a message is displayed saying “validation failed when saving multiple assets, check Data Validation log”. The message log then displays the following:

(file path of my map) contains invalid data.
Data validation FAILED. Files Checked: 3, Passed: 0, Failed: 1, Skipped: 0, Unable to validate: 2

I’m not sure how to replicate this in another project partly because I’m not sure what this even means. I can’t even find anything about this error anywhere. What does it mean for a map to contain invalid data? I have yet to notice any ill effects and to my surprise, the game can even successfully cook and package itself. The only negative effect seems to be the message itself, so I’ve also considered that this could be a false positive as well.

What I’d like to know is what I should do in terms of trying to diagnose what is causing this. All I know so far is that error consistently appears on only two of my maps, but no other significant side effects have been observed besides the error messages themselves. Neither map has any blueprint nodes within them, but both are loaded into the game via level streaming.

1 Like

can you screen shot the error log

Every time I save either map, the message is displayed. This particular screen gets replicated with my project whenever I restart then proceed to save both levels individually.

For what it is worth I am getting the same error. It started for me when I refactored the AI Perception Component from BP to C++ on my NPCChar Class. Now I get this strange error message, but as best I can tell the class is saving. I am on 4.21.2

Same thing is happening to me, whenever i create a bp class from c++

I abandoned my project… Not because of the error, just wanted to start fresh. Sometimes when you are messing around in C for a class that has a BP child you can get weird results. The solution that has work best for me is reparenting the BP to AActor and then back. You lose any modified parameters, so filter to modified parameters and write them down first. Seems to fix a lot of ghost issues.

I also have the same error and cannot find anything to fix it. We also upgraded our engine version. From 4.18 to 4.21.2.
On my side, I do have blueprint nodes in my level blueprint, but their functionality remains normal.

Reparenting worked for me, thanks

It’s not working for me. I still got the same error. =(

Renaming the levels seemed to do the trick. I’m not sure how it happened in the first place, but it seems to be working now.

Delete config folder and resolve

It worked for me. Thank you so much!