Valid Development Provision and Certificate ignored for tvOS [Workaround]

Update: [Here is a screencast of the entire process.][1]

Steps to Duplicate:

  1. Create First Person Blueprint project, “Desktop/Console”, “Max Quality”, “No Starter Content”
  2. Set bundle information.
  3. Import a development certificate and provision.
  4. Attempt to package for tvOS or to Launch on AppleTV

[Here is the Output Log Snippet][2]

This is what it looks like.

CleanCut,

As we discussed on your previous AnswerHub, you’re going to reinstall your Mac OS and see if that fixes the issue. However, here are the steps where I was able to resolve my issue with the developmental version of tvOS:

  • Closed the Editor
  • Removing my provisions from the provisioning profile
  • Opened the Editor back up
  • Added only the Provisions that I needed for tvOS
  • Added only the certificate that would be used for tvOS
  • Packaged the project for tvOS

This corrected the issue for me. I know you have double checked multiple times that you’ve used the correct provisions and certificates, but you might need a complete refresh.

There was some provisioning logic changed when Xcode was updated therefore, any older certificates/provisions were causing errors during packaging.

Upload new logs as you continue testing, please.

I didn’t anticipate 4.14.1 coming out while I was doing my fresh install…interesting. Unfortunately, not any better.

  • From-scratch installation of macOS Sierra 10.12.1 and UE 4.14.1 - no restoring from backups.
  • Description

117950-screen+shot+2016-12-08+at+4.40.49+pm.png

  • Packaging

  • Imported development certificate and provision (this used to go green in 4.14.0, even though it didn’t work)

  • Error

[link text][5]

I want to be sure that I’m following the correct certificate/provision process, so I’m redoing everything else now:

  • I deleted my certificates from Apple’s developer site and generated new ones.
  • I deleted my old certificate from Keychain Access and my old provision from ~/Library (the ones added in the last attempt before I nuked the certs on Apple’s site)
  • The newly generated certificate and provision imported green, but still didn’t work (see [attached log][1])

  • Here is how I generated the new certificate and provision:

I did all the same things as in the last post, only using a wildcard app id and a provision that uses it. Same [errors in the logs][1].

I really don’t see how I could possibly have gone more “from scratch” than this. I have worked on this every day since November 26th. I have tried 5 versions of UE (including source builds), two versions of macOS each on two different macs, reinstalled macOS Sierra from scratch and all programs from scratch, deleted all my certificates, app ids, and provisions and recreated them. I don’t know what else I could possibly do! From my perspective, the tvOS feature has been completely broken for both development (this post) [and for distribution][2]. Lousy timing for me to try to release my first commercial app. :frowning:

Perhaps you and/or the tvOS developer could try a “completely from scratch” setup? Something! Anything!

Also, I am willing to send you the certificate and provisions via some more private means and you can test with them yourselves. Just let me know if you want to try that and I will arrange for you to download them.

I was able to package (in development) for tvOS in 4.14.1 on macOS Sierra without any trouble. Could you please submit your provisions and certificates to me through a private message on the forums?

Thank you. :slight_smile:

CleanCut,

Please check the information I posted on your other AnswerHub. Please let me know what I can do to further assist you with the problem you’re running across. Hopefully the tips provided help figure out what’s going on.

Thanks!

As I mentioned in the other post, I have no idea what to change in the certificates/provisions in order to make things work. The certs work just fine with iOS provisions. I can’t see anything to do differently with the tvOS provisions. Feels like a cop-out to me.

That is really not a helpful answer. I tried making my certificate and provision names simpler. I can’t see anything else I could possibly change.

Your set up looks fine from the screenshots provided. However, it looks as though you’re using a .cer file as the certificate. If you’re attempting to use this on a Mac other than the .CSR, you’ll need to generate a .p12 in Xcode. .cer files will only work on the computer that the .CSR was generated on.

If you’d like, we can further debug the issue if you could provide us with the .p12.

I’ll post this on your other question too, just in case - thanks!

I left a comment in the other post detailing how I am unable to generate a .p12 file.

Please help. - YouTube

I watched your YouTube video and I did not notice any mistakes in your certificate and provision creation process.

Follow the .p12 setup process found on the website Calvium. The guide is very direct and detailed. I was unable to find much information within our released documentation for the .p12 creation process.

Sorry for the delay, holiday hours make our response time longer than usual. I hope you have a great New Year! (Minus this current headache).

In the other thread about the distribution side of things, I found a workaround that gets past the development issues. The workaround doesn’t get past all the distribution issues, though. :frowning:

Any updates with this? I am having the same issue with packaging for iOS where none of the proposed solutions work.

Not that I’m aware of.

Were you able to get it onto iTunes connect in any way? Or are we just waiting for them to fix the issue.

No. I have not been able to get a tvOS package submitted to iTunes connect under any conditions with any version of the engine.