Download

V-Sync issues despite having FPS staying at constant 60 FPS

Hello Everyone! (Hope this is the right place to post this)

Ever since I downloaded version 4.26 of Unreal Engine I have noticed that I have very noticeable screen tearing, so I decided to use V-Sync at constant 60 FPS, and to my surprise the screen tearing continued to happen. I am completely lost and tried to find every resource available to fix this issue, but no luck. I have an RTX 3070 with the latest drivers downloaded, but I am guessing this is more software related.

Help will be greatly appreciated!

Here are some screenshots of this issue.

The game constantly runs at 60 FPS with the FPS being locked at 60.

Withn PIE it doesn’t mean anything.
you have to test in a launched application. Possibly packaged for release. And set to full screen, not windowed.

Your 60fps also doesn’t mean anything at all. particularly if you are set up to use DX12. The fps readout from the engine is one thing. Anything else pretty much won’t work with dx12.

16.7 ms to render a near empty scene seems like a really, really high number for a 3070.
You are probably doing something you shouldn’t like SSGI or ray trace that kills performance - if it’s what you need, i guess it’s ok.
but you also need to consider that at 4k the test projects run at over 90fps (9ms) on a 1080ti.

the frame limiting could be injecting into the render cost to achieve the 60 count. Remove it. Let the scene run at max performance instead of limiting to get any sort of meaningful result.
and yes, this is all very much related to vsync screen tearing.
If you don’t limit anything, the tearing should stop within PIE as well.

Hello thank you for providing me help.

I did remove the FPS limit and now the FPS is at 8 ms at 120 FPS. Thank you about this!

The screen tearing still occurs in the project. I am unsure what is causing this still.

Unfortunately I can’t launch projects due to this bug where my editor crashes, which is another issue.
4.25.0 Launch freezes engine - Unreal Engine Forums

Replying here for that too.
figure out how to verify engine files. Or, move the project to a safe location. Uninstall the engine. Reboot. And re-install it.

Something is obviously amiss with the engine files.

For the editor you have to set r.vsynceditor 1. I think Epic has produced more CO2 than crypto by defaulting this to 0. It’s only a useful setting for profiling GPU, otherwise it just wastes a lot of energy.

I may have set that up in my engine ini. Honestly can’t recall.
but generally speaking the engine shouldn’t tear up with or without vsync if above the FPS amount matching the hertz of the monitor.

Either Unreal has issues, or the gfx configuration does.

Since stuff hangs when you play in PIE, I think the engine is at fault.

I tried everything listed above, reinstalled engine, verified files, tried the command, unfortunately the screen tearing is really hard to develop in, unfortunately I will just wait for the next UE update, whether that would be 4.27 or 5.0.

Thank you for trying to help, but I am guessing its engine, as its not the only bug I am having with my engine.

Gave this issue one last try, so when I tried smoothed frame rate, it seems that the max 60 fps isn’t being applied neither when being run or in the editor.

Smooth fps attempts to adjust, but if your GFX can’t handle it will drop below the minimum.
as you learned, it pads the ms cost to keep a consistent frame rate output.

/ it really has little or nothing to do with vsync, or screen tearing.

Are you now able to run the game in PIE? Has that been handled?

Hello, so I found sort of a solution by going into the NVIDIA control panel and turning on adaptive v-sync which fixed the issue for me, though it runs at 16 ms, so that might be a problem, also a little ghosting around the character when moving, but I am fine with this ghosting occurring. I am though confused if the smooth fps works as my FPS wasn’t lowered to 60 for the max before using the adaptive v-sync. The Launch seems to be working again, must’ve been a bad launch of the editor?

Generally pie (play in editor) either works or you have a bad installation / corrupted engine files.

Remove smooth fps/frame limiting to see what performance is currently at.
Either way, the editor is not really a reliable source for performance monitoring.
a published game can get a little more juice than the editor. Particularly when you start opening a ton of editor windows.

Hello so pie does work good I think, about the smooth frame, do you know why the smooth frame isn’t being applied when playing in the editor?

No clue.
try using the stat commands
stat unit
and
stat fps

To display the actual frame count inside pie.

When smoothing/limiting is enabled, normally the frame count stays consistent.

Again, you are really only supposed to turn this function on in a finalized project, or you have to turn it back off to debug performance anyway.

Hello I can’t find those commands unfortunately, about the smoothing, you are correct this only works when the project is launched.

I will just use the NVIDIA control panel method, as the r.vsync doesn’t work