UV Mapping

I am trying to create a uv map for the first time for one of the FBX meshes I am importing into UE4.

So, I opened the mesh in 3ds Max 2014, I used the modifier Unwrap UVW, clicked Flatten Mapping under Mapping and got this:
How do I create a uv map that I can use for UE4? Thank you and I apologize in advance, I have never done this before.

The UVMap what you got, can be use in UE4, but you have to increase the Lightmap Resolution to get good Shadows. Make sure the Map Channel is set to 2.
I would check out some tutorials for unwrapping, this can go very complex sometimes, it tooks me a long time :smiley:

Ok thanks :smiley:
If I were to use Quixel or Substance with this, how would I go about doing this?

Another industry tool you could put into your toolkit is xNormal (it’s free). Take a low poly mesh and a high poly of the same object and plug them into xNormal. It can bake normals, ambient occlusion, cavity, height maps and more. It also has a 3d viewer to combine everything to see the final result.
It can be part of the workflow with Quixel and Substance, just more options to explore.

You can add another Unwrap UV Map modifier and create the same UV and move it to channel 2 for your lighting.

Hello BiermanM!
First of all I recommend you to fix problematic areas in this mesh, I’m talking about polygons with 5+ sides in particular. You will get a tons of different sorts of errors with mesh like this in game engine.

You need a good UVMap for texturing.
Like QBert says, if you had one you can just copy ist to the second UV Channel to get the best result.

I’d just like to point out that you probably wanna clean up that mesh first. It has lots of unnecessary faces.

It’s probably hard to tell from the image, but the mesh actually has a lot of curved faces, which is why there are so many. Would it be easier for the game engine and uv unwrapping if I were to make all of them flat?

Also, how would I combine the faces of the yellowish half cylinders near the bottom of the mesh in the uv map, since they are meant to be tubes? Because right now when I import the mesh into UE4, it doesn’t look very smooth
http://snag.gy/zVkAF.jpg – here’s a screenshot of it