UV distorted after displacement tool

So I was trying out the displace tool in modeling tools, then I noticed uvs distortion increases at one end of the mesh.

As pictures shown, there’s UV distortion at the end of the mesh.
Create a plane → Scale to desired size (Around 10:1) → Unreal merge to sm (To apply the scale to prevent issues) → Unwrap in modeling tools → Remesh in modeling tools for displacement → Displace tool.

Distortion happens after using displace tool.

I’d like to know if there’s a reason causing this? And is there a workaround to prevent this?
Of course I can do it in blender then import it, but that defeats the purpose of having the tool.

Okay so the distortion fixed itself after using simplify tool. But it’s still a weird behavior nonetheless.

A couple quick questions to see if we can reproduce the problem you are seeing.
-Looking at the images it is hard to see what the actual UV’s are doing can you share a snapshot of the actual UV’s either from the uv editor or static mesh editor.
-Are you using the first image as the displacement source? Can you share what settings you are using for the displacement?
-also instead of doing a “merge to sm” you can use transform-> bakeRS which will give you few extra options to bake scale and rotation.


Here’s all the extra information I think is relevant, hopefully it’ll help.

  1. Here is a screenshot of the UV map in mesh editor (After displacement), but I think it has not much use since it’s too dense to make sense. (The white bar on the left)

  2. This is a texture asset imported directly from bridge in UE5 (The “Dirty Brick Floor” material).
    Using the blue channel of the ORD map as displacement.
    Displace settings:
    And of course the material is also scaled by 2.

  3. BakeRS is not usable in this case as it is an engine mesh (Default plane)

More detailed steps:

  1. Empty Scene. Create a plane from the “Place Actors” window.
  2. Scale to 1/10/1
  3. Merge to SM
  4. UV Unwrap tool, default settings
  5. Displace tool with above settings

Then the distortion should be seen on one end of the mesh, in this particular case it looks like this

Expected behavior: UVs are sampled/interpolated correctly, no distortion.
Issue: Small blocky artifacts can be seen at one end of mesh, which seems like uv distortion.

Tested again and confirmed above steps can reproduce the issue on my machine.
Driver is up to date.
Detailed system info (Sorry it’s in Chinese):
NVIDIA System Information 09-20-2022 00-36-13.txt (3.2 KB)

Thanks for the additional info. A couple additional questions, where are you doing the subdivision of the mesh? The settings you show for displacement have the subdivsion level at 0. Also can you circle the artifacts you are referring to in the image. A additional suggestions also would be to use the modeling mode shapes instead of the engine placement ones. The modeling mode shapes have a lot more control and will allow you to set size, subdivisions and polygroup structure.

Sorry for the late reply, somehow missed the notifications…

  1. I do subdivisions beforehand using the remesh tool, so I left the subdivision settings at 0.
  2. I highlighted some patterns, the texture became wobbly and jiggly. It’s quite subtle but it’s there.

And again, I do think this is a bug. There are many workarounds but it still shouldn’t happen

Remesh will distort the existing UVs. It tries not to, but inherently the operations it does to refine the mesh will result in some shifting of the UVs relative to the surface. It can be subtle but it’s not a “bug” in the sense of a mistake that we can fix, it’s more like a mathematical property of the remeshing strategy, it wants to slide the vertices “sideways” on the surface, while their UVs stay stationary, which introduces distortion. We try to constrain the vertex movement so that the UVs won’t become distorted but it sometimes is not possible.

If you want to post your mesh I can have a closer look but I would guess that this is where the distortion is coming from.

Alright then, tbh it’s way too subtle that unless your doing a heavy close-up, it woudn’t even be noticeable. I’ll mark @rmsEG’s comment as solution. Thank you all again for clearing this up.