UV Channel not Importing

Are you importing it or re-importing it? I’ve had trouble getting my second UV channel to come in before, when reimporting. I just deleted the mesh from UE4 and imported again as a new mesh, that’s helped before for me

Okay that’s interesting, I’ve brought the model in to the engine myself. I got both UV channels show up.
However, nothing was in those channels for me. I might try tomorrow when I have access my PC which has a newer version of the engine. I’ll let you know what happens then

I imported it into blender just before and the UV maps didn’t show there either. I think this might be an issue at the modeller end

I am having an issue with random objects not importing their UV channels I have created in 3ds. I do the same process for many different objects and import the object into UE4 and the second UV channel comes in fine. But seemingly randomly, like the model I am currently working on, no matter what I do, I cannot get a second UV channel to import. I am doing nothing different, so I can’t seem to figure out what is going on. Has anyone ever had this problem?

Here is a link to the FBX file I can’t get to work:


I have had trouble getting the second channel when reimporting as well. This one doesn’t seem to want to work no matter what. I tried reimporting and deleting the mesh and importing it. I even tried starting a new project all together and importing it. Nothing seems to want to bring in the second channel.

Sorry for the year later bump, but I had trouble when reimporting after adding a 2nd UV channel too. While experimenting I unchecked ‘Generate Lightmap UVs’ in the LOD0 and Import Settings dropdowns, saved the asset, and then reimported. Then I rechecked generate lightmaps and now I have both of my channels, plus the 3rd generated by UE4 for the lightmaps. Hope that helps someone.

One Extra bump for anyone else viewing this today, make sure that when exporting your UVs (in my case from Maya), that you have the UV Set 1 as your main set, or the current one when exporting. For some reason having it set to anything besides 1 means UE4 won’t load the the rest of the sets.

This helped me! Thank you