Utilities->Casting Menu & Options Missing

Recently when working through this tutorial I’ve found that I am unable to proceed due to the problem in the question title. When I attempt to find casting options there are none listed in the utilities menu, or anywhere else for that matter. I have unchecked the context sensitive box to see if that would show some casting options and that did not work either.

To see if the problem was limited to widget blueprints only I attempted to find a casting menu/submenu in a pawn blueprint and that didn’t work either. I verified this time also that the context sensitive check box was both enabled & disabled.

The tutorial initially shows the casting options around 6:29. My guess is that this problem may have to do with the tutorial written during UE4.4 and I am currently working with UE4.5 although I would have thought that some casting options would have been available in the pawn blueprint. Thanks in advance for any assistance.

Hi ra_ar,

This is a known issue in version 4.5 that has been fixed in the upcoming 4.6 release, they were switching over to a new menu system and a couple of these issues occurred.

It should show the proper Cast To nodes when you pull out the blue object wire and type “cast” with Context Sensitive un-checked, but if it is not go into Edit → Editor Preferences, select the Experimental tab and have a look to see if “Use new blueprint menu system” is turned on or off. It should work as described when it is turned off, so change the setting and then try it again.

As mentioned this has been fixed in the upcoming release, so you won’t need to do this in the next version. Hope that helps! :slight_smile:

Hi DotCam, thank you for taking the time to help. Your response has helped although the situation is a bit different than described.

I tried the typing “cast” with context sensitive unchecked while pulling a blue object wire as you described (and show in the video) with the “Use new blueprint menu system” unchecked and there were no cast options available.

When I tried the same thing with the “Use new blueprint menu system” checkbox->checked it did show a large number of cast to options (after restarting the editor). Unfortunately I was not able to cast to the type shown in the video. The strange thing is that the menu did recognize the type, but did not have an option to cast to it. I verified the widget blueprint named “ScreenResolutionButton” was added to source control. I’ll keep trying a few different things and update this solution when more progress is made.

Thanks again.