UT3 QueryPort(6500/udp)


I have setup a UT3 Server on CentOS, and I have it running. However the only problem that I am running into is that nothing seems to be started on the QueryPort(6500/udp). According to some documentation I found is that if you don’t specifically have to edit the port in the configuration( UTEngine.ini or via command line option -QueryPort) that it should run on the default port. However I have tried changing the default both ways and that doesn’t cause anything to run on the QueryPort. I do see the the game Port running on 7777, so the server has started correctly. Here is the documentation I followed:


Or is it so that the QueryPort was a GameSpy QueryPort and since GameSpy is not active anymore that with the patch to play the game without GameSpy the activation of port 6500/udp was removed? If So how can I make it so that when adding an IP via the server browser that the server is seen without it giving an error on query first, and then asking if I want to directly connect? Getting query errors is going to confuse the users that are going to connect to the server so I would really appreciate it if you could help me find a solution for this.

Dear valued Unreal Tournament gamer,

It looks as though there are possibly some patches that were released to remove GameSpy integration from UT3. Have you tried searching the Metaverse for these? They may be difficult to find from trusted sources, so please be careful to make sure the patch or update has come from Epic Games directly.

Have you tried looking at the new Unreal Tournament? It is community based project and the full source is available on github! If there are parts of UT3 that you miss, such as specific gamemodes, your help implementing this would be of great benefit to the community and the future of Unreal Tournament.

Thank you for your continued support,