Using web brower plugin causes packaging crash


I have a project for Android and iOS that builds perfectly with 4.12 preview 3.
However, when adding the web browser plugin for Android (have not tried yet with iOS), it crashes.

Here is the output:

MainFrameActions: Packaging (Android (ASTC)): UnrealBuildTool: ERROR: Attempted to use UEBuildBinaryConfiguration.OutputFilePath property, but there are multiple (or no) OutputFilePaths. You need to handle multiple in the code that called this (size = 2)
MainFrameActions: Packaging (Android (ASTC)): CommandUtils.Run: Run: Took 2,5715282s to run UnrealBuildTool.exe, ExitCode=5
MainFrameActions: Packaging (Android (ASTC)): Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Command failed (Result:5): C:\Program Files\Epic Games\4.12\Engine\Binaries\DotNET\UnrealBuildTool.exe …

How can I fix this?


Hey Guillaumeb,

  • Can you please upload the full error output logs as a .txt file? You can attach it with your next reply.
  • Can you also test and see whether or not this is happening on a blank project?
  • Does this happen in 4.11.2?
  • Are you receive the same error with 4.12.0 Preview 4?

Looking forward to hearing back from you, thanks!


I have created a very simple empty scene with 4.12 preview 4 just with a UMG calling a URL with web browser widget. It works fine in viewport.
When I package for Windows 64 for instance, packaging fails again - same problem as with my previous (more complex) scene. I am attaching the log. I unfortunately did not / can not test with 4.11.2.

[link text][1]

91050-log.txt (7.65 KB)


After multiple runs on my original scene for Android, I found out that the webbrowser plugin was working (ie not generating build error) only for armv7. If arm64 was activated, this was giving the error. So I suppose that there is some bug with web browser plugin and arm64 build.

Voila :slight_smile:

Just one question then, is web browser plugin working for iOS? It is listed as new feature for 4.12 but I dont see anything about iOS in plugin folder.

It looks like UE-30806 is a bug which is currently in testing. It states that there is a missing plugin error on iOS when the web browser widget is used.

Building package for Windows x32/x64 with Web Browser plugin turned on causes error.

Any ideas/workarounds?
Packaging settings:

  • Shipping or Development
  • All platforms or Windows only (x32/x64)
  • For Redistribution
  • Blueprint project

Well, with Windows SKD 10 installed it packaged without errors. Yeah!