Using Vive Motion Controllers with Widget Interaction not working

Hello guys, i’ve got a strange problem which already took me days to solve (and obv i still couldnt solve it :p)

I want to use my vive motion controllers to interact with my umg widget (thats all for now.)
I got a Player-Blueprint which creates the left and the right hand controller on begin play. in my right hand controller (this is the controller i want to interact with my widget/menu) i set up a widget interaction component as you can see here:

My Player Blueprint receives incoming inputs from the motion controllers, so if i press the right trigger button, in my player blueprint i set my press and releaser pointer keys with the target of my right hand widget interaction.

What happens now is that my 3D-Widget is attached to my left hand motion controller. When i hover over it or click on it, the hovering effects actually HAPPEN and the click effect happen aswell, but THATS IT. When i want to write some logic behind onClicked or onPressed nothing happens - when i click on my 3D widget with my right hand controller, nothing happens at onClick, but my widget interaction still kinda interacts with my menu because when i hover over it or click on it, the effects work. I dont know what to do i tried so many things but nothing happens. When i play my game and simulate the menu blueprints nothing happens when i press or click or hover something, just the effects in the designer graph works.
I would really really appreciate if someone knows the answer and could share it with me.
Best regards, .

in my left hand controller BP i create 4 widgets which will be placed around my hand. Maybe there is an error there?

Hello guys, i think i solved the mystery. My Interactions actually worked, only it seems that while ingame the simulation of a Menu blueprint is not working properly. Thats why i was confused that the interactions wont work. Actually my functions didnt work.

Hi ,
I believe we have the same problem I however cant figure out why my OnClick events on the buttons wont work. I can hover over and the button change to hovered but i cant click with the right MotionController trigger to fire the on clicked event. Do you know of anything i could do to fix it?

i tried using the f key instead of the trigger and it worked fine.