Using Unreal Standard Animations on Imported Blender Actor (Model)

Hey Guys
Are you able to import an actor (model) from Blender and use the Unreal engine animations that are provided?
If so are there any steps/youtube guides ?

Thanks in advance


you need to give the model some bones in blender, the same amount of bones that already in the animation you want to use.

Then you use the “Retarget” tools in UE4, here is a video showing how you do it in the engine.
Then it should work, ive experienced some bugs now and then, but usaly it works.

Thanks WideBoy

Just to be clear : if your custom model is using a skeleton that is completely matching the UE4 Male bone structure, you will not need to retarget anything - the default animations will work right away. Example here using a compliant model from the marketplace :
Animation retargeting is a fantastic tool to port over animations coming from a custom source to the Epic Male standard. But if you are using it the other way around (that is to say, porting default Epic animations to a model that does not follow the UE conventions) then you will have issues later down the line.

What kind of issues? I’m using a mannequin like rig (ue4tools) and have done a lot of retargeting without any issues, both the animation starter pack animations and mixamo animations retargeted to the mannequin and after that retargeted again to my skeleton. Even if they were not the same you could fix it by setting up the base pose correctly.

Hi there again Cyaoeu !

Even though things can always be “duct taped” after that fact, incompatibility issues can always arise unexpectedly. For instance, for my own characters I used to use a skeleton that was mostly compliant with the Epic one, but not fully. It certainly worked fine through to retargeting, and that was okay for a standalone project ; but then I realized that such an asset can not be sold on the marketplace since it is not directly usable with the official Epic content, and retrofitting it to the proper official skeleton wasn’t as easy as it seems. That’s one of the many issues that can arise by not following the standards. It’s always best to be careful and conservative about that sort of stuff.

Therefore, if someone wants to use standard Epic content (default animations, game examples, and so on) with their character, my advice would be to first and foremost make the character fully compatible with the Epic Male, rather than using a non-standard skeleton. It may take some initial time and effort, but once that is done every animation pack becomes fully compatible with the character without any need for extra work and no need to create duplicates of animation files. It also makes prototyping much smoother, since any Marketplace content and game type examples will work flawlessly with the custom character.

Trying to do this for a weeks by now with no results. I followed at least 3 different tuts on youtube (apart from official) step-by-step.

At first, there’s no “animation” window in editor after importing:

Then, retargeting not working as well, mesh just going mad:

I even tried a UE4 tools cyaoeu metioned, so there’s definitely no problem with bone hierarchy.

Why are you adding the same skeleton as the retarget source? Remove that, just add Humanoid for the mannequin skeleton and your own skeleton, then try again, it should work.

Because i barely understand all of that.
I managed to create my char from the scratch in zbrush and make topology and uv’s in blender and even some materials in substance, but when it comes to rigging and exporting to engine i just stuck.

So now mesh is not going mad, wich is good. But animations is not playng, she just stands there:

Seems to fbx exporting problem, but again, no idea:
26e6482f97e8f8fe1b8413018a82b482.jpg b2b081b2980d02a6768bc90145844a71.jpg 0e368f7cd202a61ff0c528f5a2ae6a49ff8aee8b.jpeg 659e6679eeb4411a726a065ff0b4a519.jpg

You need to enable Baked Animation.

Mesh gone mad again, but this time it’s actually moves and looks creepy .__.


I’m having the same issue with my re-targeting mesh from MakeHuman, i posted an answerhub question about it,

Everything is else is working but the fingers are driving me crazy

ok i finally managed to apply standart animations to my mesh and it looks fine:


howewer, when i applying animations from Epic’s Starter Pack, the mesh is increasing in 100 times:


any tips?

It’s a base pose problem, but it’s a pain to fix in the editor. If you can share the .blend file I can try to make a Blender script to fix these issues.

You’re probably not using metric 0.01 scaling, any other scaling causes issues in UE4 (for now, see
Probably easiest to change to metric 0.01 scaling, scale the rig to the correct size and apply transforms for the rig and mesh, then export again. Retargeting should work better then.

That’s funny. Now, when i changed my metric to 0.01, the Starter Pack Animations is retargeting as they should:


And Default animations is not retargeting again:


any way to make both of them right?

ok look’s like all fine now.

I applyed Humanoid rig to my mesh and both of the mannequins from default third peson project and anim. starter pack and did retargeting again.
Without that, even mannequins could not sharing animations with each other, wich is funny since they both from epic.



Thank’s for your answers, cyaoeu.