Using Unreal Engine 4.12.5 Freezes Macbook Pro

OS: OS X Yosemite 10.10.5
Unreal Engine 4.12.5 AND 4.10.*

Every time I open a project or start a project with Unreal Engine 4.10.1 and above, and after about 1-2 minutes of use (I timed it), the whole computer, not just the engine, freezes for a minute or two and then restarts by itself.
This only happens with Unreal Engine, and I tried with other programs, but it does not happen.
When the computer restarts, all of the apps and browser tabs that were open before the restart are re-opened by the computer. All except Unreal Engine.

It is also important to mention that until yesterday, it has been several months (don’t remember exactly) since I last used the Unreal Engine, and I never had this issue before. Sure it had some “hiccups” or tiny issues that did not cause any crashing or freezing of anything, and it worked.

This is the first time that anything like this happens.

Some additional information:

  1. Sometimes when the computer freezes, a very strange screeching sound is made, not from inside the computer, but from the speakers/headset.
  2. I deleted everything for Epic Games, and the Unreal Engine, and re-installed them. However, the same problem occurs.
  3. I checked the activity monitor while the Unreal Engine is running, after choosing or starting a project, and I could not notice anything unusual for the energy usage, memory usage, or cpu usage. I could not get screenshots either since I cannot predict when the computer will freeze and auto-restart, and it happens randomly between 1-2 minutes.
  4. I installed the Epic Games Launcher and the Unreal Engine on my Windows 10 partition, and the exact same thing happened as well. Unreal Engine 4.12.5 that is.

More Information as Requested
System Specs:
MacBook Pro (Retina, 15-inch, Mid 2015)
Processor 2.5 GHz Intel Core i7
Memory 16 GB 1600 MHz DDR3
Startup Disk Macintosh HD
Graphics Intel Iris Pro 1536 MB

Hardware Overview:
Model Name: MacBook Pro
Model Identifier: MacBookPro11,5
Processor Name: Intel Core i7
Processor Speed: 2.5 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB
Boot ROM Version: MBP114.0172.B09
SMC Version (system): 2.30f2

As for storage there is 68.45 GB free for the OS X partition + 31.13 GB free for the Windows 10 partition.

Diagnostic Report File: [.diag file][1]
UE4.log: [link text][2]
ProjectName.log: [link text][3]

Also, I found something curious although I am not sure if it matters.
In the /Users/Shared/UnrealEngine/Launcher/SelfUpdateStaging/Install/ the Epic Games Launcher application has a white circle with a line through it for an icon. Is that normal? Does that mean it was not installed properly?
Also, when I search through the app’s contents Contents/UE4/Engine/Binaries/Mac the CrashReportClient also has a white circle with a line through it. While Contents/UE4/SysFiles/EpicGamesLauncher/ directory is empty.

Screenshot

Hi M215,

Regarding the .diag files, please send one from a known time when the freezing has occured.

We’ll also need the following:

Your Mac’s specs. You can find this in the Apple menu >About This Mac>More Info> Add the information from this window (serial # not necessary)

The “System Report:” Apple menu >About This Mac > System Report>Hardware (All information listed in the “Hardware Overview.”) You can cut and paste this information or provide screen shots, whichever is more convenient.

The UE4.log (Located: ~/Library/Logs/Unreal Engine/Editor/)

The ProjectName.log (Located: ~/Library/Logs/Unreal Engine/ProjectNameEditor/)

If the Crash Reporter window is ever present when the crash occurs, select “Copy Callstack to the Clipboard,” and paste that information in a document and add to this post. Be sure to hit “Submit” on the Crash Reporter pop-up to send the Crash Report to Epic.

Also, approximately how much storage do you have left on your Mac?

Please provide as much information from above as possible.

Thanks,

Steve H.

Hi Steve Hardister,

I updated the post as requested.
Except for the following:

  1. The UE4.log (Located: ~/Library/Logs/Unreal Engine/Editor/)
  2. The ProjectName.log (Located: ~/Library/Logs/Unreal Engine/ProjectNameEditor/)

I could not find them.

Thanks,
M215

These are hidden files… In the Finder, navigate to Go>Go to Folder -then type the path as shown above, starting with the ~. Please provide these, thanks.

*Let me know if you still cannot find these folders/logs.

I uploaded them. The links are at the bottom of the “question”.

Regarding the Epic Games Launcher application having a white circle with a line through it for an icon… this is not normal.

  1. Make sure to back up your Unreal Projects folder to a safe place
  2. Remove all versions of the Editor from the Launcher library by clicking on the down arrow and selecting “Remove”
  3. Uninstall the Launcher
  4. Re-install the Launcher
  5. Download and install Engine version UE4.12.5
  6. Open a new Blank Third Person Template Project
  7. Does the Engine freeze or crash?
  8. Repeat steps for your Windows 10 partition.
  9. If Windows 10 is functioning with a blank project, then there is likely a problem with your custom project, most likely a problem with the persistent level.

I’ve removed and re-installed the launcher and the game engines several times now. The problem did not go away. Also, as far as the custom project, I never got anywhere far with it since 1-2 minutes after I open a project or start a new one the whole mac freezes and then restarts. So, there is nothing in the project.

I will however try again for both the OS X and Windows.
I will let you know within the next 20 hours since I am not currently free.

Ok, so I removed and re-installed the Epic Games Launcher + the Unreal Engine 4, and the problem persists just as before.

So any updates? Is there need for more information?

Please verify that you are downloading the Launcher from the Epic Website and not building from source via Github.

If you’re building from source, you will have to generate XCode files and build the components in this order:

  1. ShaderCompileWorker for Development
  2. UnrealLightmass for Development
  3. CrashReporterClient for Shipping
  4. UE4 for Development Editor

If you are not building from Source, Please send a screen shot of the white circle with line crossed (No Symbol) Also see the following site for Launcher-specific help:

Support Center

I did not build from source, I did download from the Epic website.
I also uploaded a screenshot of the app. It is at the bottom of the post, above the replies.

Also, just to make sure the app icon I was referring to is in this directory:
/Users/Shared/UnrealEngine/Launcher/SelfUpdateStaging/Install/

The icon shown above is a white sheet of paper with a triangle made up of a pen, pencil, and ruler so this is normal. (I thought you meant the “no” symbol). Your install looks correct as far as I can tell.

Just to reiterate; This behavior does not occur in UE4.9 or below? Please test again.

Also, delete/replace the DerivedDataCache folder located here: UnrealEngine>4.12>Engine>DerivedDataCache
*If it’s there, delete the contents. If it’s not there, create a folder and make sure it is spelled and capitalized exactly.

Finally, the log found in this post is similar to yours:

https://forums.unrealengine.com/archive/index.php/t-100933.htmlj

As it says there, make sure you do not have an expired certificate on your Mac -instructions are on that forum post.

One other thought… theres a message in the log stating:

Guid format shader working directory is 15 characters bigger than the processId version (../../../../../../mohammadabouchama/Documents/Unreal Projects/SimpleDigger 4.12/Intermediate/Shaders/WorkingDirectory/1116/).

Which leads me to believe the length of your working directories exceeds the maximum 120 character limit. You can test this by creating a new-temporary user profile called “test.” Install and launch UE4.12 and create a project called “Test1” If you do not experience this behavior there, you can fix your directories in your primary profile and delete the test profile.

Hi M215,

Since we have not heard back from you in a few days, we are closing this post for tracking purposes. However, if you are still experiencing freezing on your MacBook Pro, please respond with all requested information from the previous two posts and we will continue to investigate.

Thanks,

Steve H.

Hi,

Sorry for the late reply. I have tried your suggestions for several days now. And one of them, the deletion of DerivedDataCache worked. The other suggestions did nothing. So, so far, since the deletion of DerivedDataCache, Unreal Engine 4 has worked without any problems. However, I did not use it extensively, and I just did simple tasks. If anything does happen I will let you know then.

Thanks for your help.