Using the Steam Onlinesubsystem in the Editor?

Trying to use the Sessions in blueprint to implement a server list, however it seems to only use OnlineSubsystemNull in the editor and the correct one when run standalone. Calls still fail, but I can’t debug why since it’s standalone instead of run in editor.

Do I have to start the editor itself through Steam or is there a simpler fix?

Log shows this right after startup:

LogOnline:Display: STEAM: Loading Steam SDK 1.32
LogOnline:Warning: STEAM: Steam API disabled!
LogOnline:Display: STEAM: OnlineSubsystemSteam::Shutdown()

The Steam Online Subsystem does not work correctly with the editor unfortunately, so it disables itself if it detects the Editor present. There is no simple way to debug Blueprint based Steam code due to this, but increasing the LogOnline log verbosity to “verbose” in your configuration may help you figure out what is or isn’t happening.

LogOnline:Display: STEAM: Loading Steam SDK 1.32
LogOnline: STEAM: Steam User is subscribed 1
LogOnline: STEAM: [AppId: 480] Client API initialized 1
LogOnline:Verbose: STEAM: Initializing Steam Game Server IP: 0x00000000 Port: 7777 SteamPort: 7778 QueryPort: 27015
LogOnline: STEAM: [AppId: 480] Game Server API initialized 1
LogInit: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
LogOnline:Verbose: STEAM: Created thread (ID:23416).
[2016.06.10-09.27.47:823][ 0]LogScriptCore:Warning: FindSessions - Invalid player state

[2016.06.10-09.27.47:823][  0]LogBlueprintUserMessages: [UMG_ServerList_399] Failed
[2016.06.10-09.27.47:824][  0]LogBlueprintUserMessages: [UMG_ServerList_399] Listing:  0

It seems to fail due to an invalid player state, whatever that means. I don’t know of any Steam error that has a player state.

Fixed it, the Owning Player was disconnected due to me changing the function.

Do you know why the Steam OSS doesn’t work with the editor? Any sort of issues arise with it?

1 Like