Using the Sequencer: Bad first frame every camera change


I’m currently working on a short film using Unreal Engine’s sequencer.
I have many Level Sequences, one for each different camera shot (using the “camera cuts” track), that we then put into one big master sequence (into the “shots” track), so we can play the movie in it and that’s where we added all the characters and animations.
The issue is when we render the film, each time the camera shot changes, the first frame is bad. For example, in one shot, the first frame is missing the reflections in the water, but they appear in the second frame. Or another example is that the lighting in the first frame will be different than the rest of the frames.

This is kind of driving me crazy and I would appreciate any help, thanks!

Try setting a delay before the shot warmup. Sequencer will pause to allow things to settle on the shot boundaries.

And what about rendering through Movie Render Queue? Is there similar settings for warm up?
I have wrong frame blending between some default camera or previous camera in the first frame of any camera cut or shot. It is very annoying.

yes! I can’t believe there was such an easy fix in Sequencer and yet somehow they messed it up in the newer Movie Render Queue…

I had this same problem and found a solution. Your Temporal Sample Count in your Anti Alias settings needs to be greater than 1. I had the same issue of a bad first frame every camera cut and this fixed it.

1 Like

This almost fixed my issue of missing frames on each new camera cut in 5.0.3

I even increased the number to 4. Now I get some weird half faded frames. For now I’m having to manually cut these out in post production.

I don’t think this is your issue but worth checking:
Be aware that the camera is always calculating where it was to where it is for this first frame with motion blur.

Simply tick this then it solves your problem. It take me a while to find it, work in 5.0.3