Using the Create C++ Class from file drop down menu breaks entire project every time.

Any time I use the “Create C++ Class” from the editor ( that is already running through visual studio ) it breaks the entire project. I’ve also tried it from the editor not running through visual studio with the same result. If I try to create the class just through visual studio, I also get a broken project just different errors like UCLASS not being defined and what not.

Here is a sample of what the errors look like.

Is this true for ANY C++ class you create? Can you create a class based off Actor?

The error messages are not liking something in your .h file. What is your parent class?

When you create a class outside the Editor, you need to “Generate Visual Studio Project Files” again.

Updating to Unreal 4.2 and using Visual Studio 2017 instead of 2015 seemed to work. Something was messed up with my Unreal install location as it was installed and working but the epic games launcher couldn’t detect that I had one installed. Probably my fault for moving the whole install at one point and thinking it would be fine.