Using Material Property Overrides causes cooking failures

Hi all,

I have been having an issue with using the Material Property Overrides (under General) in the Material Instance Editor for a cooked build.

If I override the blend mode from, say, translucent to additive some of my particle systems that use the instance refuse to cook even though they work in game when I hit play in the editor.

This issue seems to happen most consistently when two separate instances of the same parent material with two different blend modes exist within the same particle system.

Is this a known issue? Am I setting something up wrong? I have not been able to find much documentation on this, so any insight would be helpful.



I am trying to reproduce the build and cook error and so far have not been able to replicate it. Can you please take a look at the attached Test Project and modify it to match the project you are seeing the error on and repost it here?

Thank You -

Eric Ketchum


Hey Eric,
Thanks a bunch for looking into this. I may be missing something, but I do not see anything attached anywhere.

Sorry about that attached again for you.

Eric Ketchum

Hi Eric,
So I have tried and tried to get this to happen. I even tried migrating the whole project folder into yours and it still wouldn’t break.

I tried remaking the shader from scratch which seemed to cook, and then it broke again. The problem seems to be localized to a particular group of objects using one shader (whatever shader that might be). The problem does not seem to happen with other shaders we have made.

Due to time constraints, I decided to work around it for now by using two shaders instead of the one, which seems to be stable. If you have any other insights let me know.