Using FGameplayTagQuery in a blueprint resets

Hello so i am using the FGameplayTagQuery as a UPROPERTY() on the ActorComponent “Grabber” which has a pretty basic setup

however when i set the field (click save and compile, but i DO NOT close the blueprint window)

and i run my program everything runs a expected

However if i close the editor window while everything has been saved and compiled
I lose my query

Does anyone know how i can fix that?

This maybe dumb, and i have not experienced this issue, you do click the Save and close button up the top right?

1 Like

Yea i did, i found the solution for this problem, seems there was an issue with hot reload, i had to delete the component and re-add it, i found the solutiion here:

[UPROPERTY value keeps resetting on every compile - #16 by arhiDavid](o UPROPERTY value keeps resetting on every compile - #16 by arhiDavid)

PS: how do i mark this as solved?

You can not mark it solved, but HotReload is really bad, and i advise people to not use it. :slight_smile:

1 Like