Download

Using a scaleform movie for the loading (transition map)

I’d like to use a Scaleform movie instead of a Bink movie.

I’ve tried updatin:




TransitionMap=MyTransitionMap.udk


in DefaultEngine.ini, and removed and entries for LoadMapMovies under [FullScreenMovie].

However, I never see my transition map (or seem to be able to fire any kismet actions from it). My menu map just seems to pause until loading is finished, then renders my loaded game map.

Any ideas? @Nathaniel3W I noticed you had previously posted about this: Better loading screens: Scaleform GFx displaying percent loaded possible? - Unreal Engine Forums How were you able to get the scaleform movie to play?

You won’t ever see the transistion map(just empty black cube no lights map) as it is the map you go to in-between maps when your traveling to next the map. That’s when you should have your loading screen up.

Hey @Coldscooter! You can use a Scaleform movie while loading your next map, but it probably won’t be as impressive as you hope. You just have to load the Scaleform movie first, then you can stream the level in over Kismet, or start a new game with


ConsoleCommand("start LevelName?game=GameName");

The loading screen will stay up as the level loads, but it will pause until the load is finished. I don’t know yet how to continue ticking the game (and the Scaleform) while the level streams in or the new game starts.

When Bink is disabled (like with UE3 licenced source), it defaults to this animated loading screen:

https://content.screencast.com/users/coldscooter/folders/Jing/media/0d06d22e-9674-4f8a-bbdb-294a08846a84/2020-04-12_1316.png

In this loading screen it appears to be using an in-engine material for the pulsating background, and have dynamic text showing (although I’m missing the font embedding).

Does anyone know where this loading screen is coming from, and how it’s setup?

Edit: This video is a swf file: SwfMovie’UDKFrontEnd.udk_loading’

Yes dude, it is located at \UDKGame\Flash\UDKFrontEnd\udk_loading.fla

No, the pulsating background is just a simple flash animation.

I tried to disable Bink Video by just removing the LoadMapMovie entry from the ini files, however, it did not work. **How can I disable bink video? **

I was trying to make random flash movies loading, by changing this old tutorial here:

https://unrealxeditor.wordpress.com/2013/12/15/tutorial-change-loading-screens-based-on-map-using-canvas-and-no-bik-movie/

In my case, I made completely random the selection of background images (not by map), and i used a Canvas.DrawTileMaterial to show the image in full screen (I created a material with the diffuse image placed on the emissive channel).


    //Size of ViewPort in pixels
    local float SizeX, SizeY;
    SizeX    = Canvas.SizeX;
    SizeY    = Canvas.SizeY;

    // if we are doing a loading transition, set up the text overlays for the loading movie
    if (Outer.TransitionType == TT_Loading)
    {

        /* Get Random Background */
        LoadingBackground = GetLoadingBackground();
        Canvas.SetPos(0, 0);
        //this will draw the loading screen in canvas full screen mode (fit to screen resolution size)
        Canvas.DrawMaterialTile(LoadingBackground, SizeX, SizeY);

It’s working, however I would like to instead of using canvas, load a flash (scaleform) file.

Game without loading screen! (no Bink video)

\UDKGame\Config\DefaultEditor.ini
+LoadMapMovies=UDKFrontEnd.udk_loading change to +LoadMapMovies=

\Engine\Localization\INT\Engine.int
Locate the topic [GameViewportClient]
LoadingMessage=LOADING change to LoadingMessage=

Do you have a FULL LICENSE? According to what I read in the licesnse. Unless its full you can not remove the bink video.

In the message up, I mean file with the name UDKFrontEnd.udk_loading.bik
Yes it’s in license, cannot remove UE3_logo.bik