UserGameSettings.ini doesn't change resolution

I’ve read several answers for changing the resolution of a packaged build. I understand that I need to go
[gameDirectory]\Saved\Config\WindowsNoEditor and change the UserGameSettings.ini with the values I want. However, a lot of these posts imply that the file should already have values written to it and mine is completely blank. If I write a section to change the resolution, then run the game, the resolution doesn’t change and UserGameSettings.ini reverts to being blank. Is this the expected behavior? If not, then how might I go about getting the file populated correctly?

I’ve already tried adding a DefaultUserGameSetting.ini to my project file’s Config folder and that didn’t seem to change anything. Also tried manually entering fullscreen which seemed to work for someone else. (https://answers.unrealengine.com/questions/124220/defaultgameusersettingsini-not-functional-anymore.html)

Also, seems like a good time to ask what is the difference between the CleanSourceConfigs and WindowsNoEditor folders. The corresponding file in Saved/Config/CleanSourceConfigs is updating so something is happening. Is one for temporary loading of configuration files and the other for back-up?

Unreal Engine 4.6.0

Nope it should go into WIndowsNoEditor\YourProjectName\Config

I used this thread as reference How to - FULLSCREEN - packaged build? - Platform & Builds - Unreal Engine Forums and it confused me at first also. I reread it a couple of times (first answer) after I got it. Also name it DefaultUserGameSetting.ini

Also in the above thread your second question is also explained a bit. But I think there is more to it where I am no help to it. Perhaps someone with more knowledge can explain the difference and why it shouldn’t be really in saved but in Config after the Project name.

The only thing I know is basically that in your project itself there is also a Config after the project name, that has some default inis and those are registering correctly, such as trace channels etc. So my assumption is it falls into the same system with the packaged one. Since there is no Config Folder after you packaged it got confusing for me at least. But now it is at least clear where to put it.

Now I found some documentation at the end of this page (Solution Directories)

https://docs.unrealengine.com/latest/INT/Engine/Basics/DirectoryStructure/index.html

Weird, I actually went through that before posting and it didn’t work. I just gave it another look since you recommended it, followed Shadowriver’s example a bit more closely and this time it worked. Don’t I feel silly now.

Turns out that DefaultGameUserSettings.ini wouldn’t apply the resolution unless I included the Version line. To anyone having the same problem, I recommend copying the entire section while following Shadowriver’s instructions. Make sure you don’t have any GameUserSettings.ini files in your Saved/Config subfolders and then when you run the game you should see changes to the game’s resolution. Now you can write to Saved/Config/WindowsNoEditor/GameUserSettings.ini if you want to change any of the listed settings again.

And thanks for giving an answer to both questions! The second link you provided doesn’t really explain the subfolders in Saved/Config though. Still, since you helped me solve my actual problem I’m happy.

No problem :slight_smile:

Just path example: UE4\Projects\PTS_Network_Test_1\Package\WindowsNoEditor\PTS_Network_Test_1\Config\DefaultGameUserSettings.ini