User Interface -> Default Cursor BP shows in PIE but not in packaged builds

I’m using a custom 4.12.5 source build.

I changed the Default Cursor to a simple widget BP image by going into Project Settings → User Interface → Default Cursor.

It works fine in PIE and standalone where the cursor will change to my custom image, but in a packaged build, the cursor is the default windows cursor.

Bug? Obscure setting I have to use? Help?

Hello ,

I was unable to reproduce this issue in a clean project in the latest version of the engine. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any settings that may be involved with this issue?

I tried to reproduce this in a clean project and I can’t and I have no idea why it works on a clean project.

All I do is create a widget BP with a custom image, set that widget BP as the Default Cursor in User Interface settings, make sure the PlayerController has “ShowMouseCursor” set to true (create a custom GameMode and PlayerController and set them to the test map).

I also tried this in pure C++ too and it works in a clean project.

I tried the same thing in my game project on a new map with absolutely nothing in it except the custom cursor image and the exact same settings/blueprints/c++ as the clean project, and it doesn’t show in packaged builds.

Why would my game project produce a different result on a clean map with the same settings as a clean project? What could I have modified in my game project to do this to packaged builds?

Is there something in the .ini files that would affect this?

Has your project been upgraded form an older version of the engine?

I think I did upgrade it actually.

I’m using a source build from a branch, at first it was 4.12 and I’m pretty sure I recompiled the engine and updated it to 4.12.5.

Have you tried deleting your saved and intermediate folders? As a note, you may way to make a back up of these folders in case you need any of their contents.

I was going to do just that, and then I retested it and packaged the game and it all of a sudden worked.

I packaged it 3-4 times just to make sure it wasn’t a fluke.

  • I changed the Default Cursor to None.
  • I reverted ‘DefaultEditor.ini’ bDontLoadBlueprintOutsideEditor to true (default).
  • I reset cooked directories to nothing (i was previously making it cook everything I had in my game project).
  • Then I packaged it.

This obviously broke my game because I depend on loading BPs at runtime for some systems that absolutely need to be cooked in that are not referenced in my maps, but I just reverted it to test the mouse cursor with default settings.

I did that last night, and it must have cleared something, because once I restored all the settings I listed (setting Default Cursor to my widget BP, modified DefaultEditor.ini and included my whole folder to cook), it worked.

Maybe it cleaned out something from before when I packaged over it with default settings? I have no idea whatsoever. It works as intended now.

Thanks :).