Download

Use plug-in which is for an older version of Unreal?

Hi, is it possible to use a plug-in which was released for an older version of Unreal?

For example MegaScan is currently available for 4.24, but if I want to use 4.25 in preview and I want to install the plug-in it won’t appear in 4.25

Is there a config file which I can edit to force Unreal 4.25 to use this plug-in? I know that the plug-in maybe will not work with a newer version of Unreal, but I want to try some stuff with new preview version of Unreal.

Same question for projects from the Marketplace, which are marked as 4.24 compatible. Is there a way to open them in 4.25?

Thank you :slight_smile:

1 Like

Locate the desired plugin folder in your UE4 install under Engine/Plugins/Marketplace. Create a blank C++ project using 4.25, close it, create a Plugins folder in that project directory.

-Copy the desired plugin folder from 4.24 engine location, to project Plugins folder you just made. Then delete the Binaries and Intermediate folders within your copied plugin folder.

-Right-click and edit .uplugin file with notepad and change 4.24 to 4.25 and save file. Open c++ project you created and click yes to rebuild plugin. If it does not prompt to rebuild the first time it is there, enable it first in the C++ project and restart project and it should prompt to rebuild it.

4 Likes

Great, thank you! :slight_smile:

Thank you!

Can this be done with a Blueprint project? Cause I’d need to install Windows SDK to make C++ projects and that would take time.

I have never done it another way, but you could just do the above, but copy the plugin to Engine/Plugins/ instead, within the engine version folder you are desiring. You could open blueprint only project, enable plugin, and see if the engine rebuilds it when reopening project. Older versions I know would not work without c++ but idk…

1 Like

I tried that but it doesn’t work. When it rebuilds, the editor just starts crashing until I delete the plugin. I tried to rebuild the plugin through, both, C++ and Blueprint projects, using UE4 editor and Visual Studio. Thing is, the plugin I was trying to convert DOES have a 4.25 version but since I had a 4.22 version and had gotten it from a friend, I couldn’t get the 4.25 one so I tried this method. Doesn’t work for me, sadly. Or maybe this works for simple plugins like plugins that add actors to your engine like the UIWS. My motion matching plugin was a bit complex I guess