USD Import Assets Error Invisible

Hi! I have question. Does anyone know how to fix the USD import in unreal engine 5?. Because when I was exporting a USD file of my assets from blender to unreal engine 5. Some of the assets are invisible and disappeared. And I have keep re-exporting a USD file project to import to Unreal Engine 5 USD Stage Editor. And nothing is still working to fix this problem. I’m having a struggle time right now. And plus I have been trying to do it in a new level map and it’s still looking invisible parts. And it shouldn’t suppose to look like that at all. It’s just strange. I think it could be a glitch bug with the USD Importer



Ok I kinda found a fix, under your USD Stage in unreal, click on the (M kind) drop-down and just select one of those settings. The reason it’s a kinda fix is that I have no idea why this fixed it.

I am having the same issue. This only started happening after I started editing models in blender and then reloading the USD scene in unreal

Oh no worries man, It’s okay. I finally figured out now. I just need to create multiple USD Stage blueprint. It couldn’t able to import all together at once. So you have to create another USD Stage blueprint, so you can have your assets still together of the way how you had it modeled in blender or any 3d software application that you use in your workflow :+1:t5::100: